Sketchfab Forum

360 degrees fallback unexpectedly appears


(Klaasnienhuis) #1

Hi there,

this configurator uses sketchfab: http://configure.zodiac-nautic.com. It works great but one user is reporting an issue. He uses chrome 57.0.2987.110 (64-bit) on a macbook air. When he loads the configurator the 360 degree fallback is shown instead of the realtime 3D model. Using safari on the same laptop loads the 3D models like it should.

This is what's shown in the console.

Also, loading any other model on sketchfab.com displays the same behavior.
Doing the check on the WebGL site (when you click "see requirements") show this message

Hmm. While your browser seems to support WebGL, it is disabled or unavailable. If possible, please ensure that you are running the latest drivers for your video card

Rolling back to Chrome 56 didn't help.
Switching the webgl 2.0 activation in chroem://flags also didn't make any difference.

Could you please assist?


(Paul Sketch) #2

It's google chrome blacklisting old/malfunctioning gpu

  • Go to chrome://flags/#ignore-gpu-blacklist
  • Enable the flag “Override software rendering list”.
  • Restart Chrome

(Klaasnienhuis) #3

@paul_sketch, thanks! This has solved our issue. Do you have any numbers on how many people are facing this?