3D Not working on any PCs

viewer
3d

(Hawkeye1) #1

Have tried seeing 3D models on different PCs and they all tell me that webgl is disabled. I have gone through each browser and webgl is enabled.


#2

Can you please post me a screenshot of this report? http://webglreport.com/


(Hawkeye1) #3


#4

Thanks! But that's not a screenshot of this report: http://webglreport.com/ :confused:


(Hawkeye1) #5

Is this what you are looking for? I have done everything I cam find to get this to work. It worked fine then just stopped. Now every time I click on 3D in Drone deploy

it freezes my PC and I have to restart it.


#6

Is it just the Drone Deploy models? Can you view other models, like on this page?


(Hawkeye1) #7

I am able to see the 3D models and interact with them from the Debug Resources page. So I'm guessing I have a problem with dronedeploy. I have talked with them and they tell me it has to be something on my pc.Not sure why this is happening.


#8

Big 3D scans like that tend to be very heavy. I suspect your computer is running out of memory. Can you give me the specs for your machine? CPU, GPU, RAM, etc.


(Hawkeye1) #9

specs.txt (4.0 KB)


(Pauljs75) #10

Make sure no scripts used by this site are blocked. (A lot are independent on each other.) You may also have to check firewall and AV settings. And in my own experience with Firefox (since that's what it looks like you're using), you may have to force some of the graphics mode settings in about:config. (But at your own risk. Might hang your browser depending on what content loads.) Try an internet search on "webgl firefox config", and go from there. Enabling/disabling hardware accel is also something that may affect this as well as plugins that tie into the browser.

In my case models seem to load fine, it's just I can't get HD textures to work. (Switching to SD works fine.) Then again I have an old computer with only 4GB RAM, and since it's using a chipset there's no separate graphics RAM to load in the larger textures.


(Hawkeye1) #11

Thanks for the info. I just don't get why it's worked fine up until about a month ago then just stopped working.


(Hawkeye1) #12

Ok. Here is what I am experiencing now. Still no luck with Firefox after going through everything I could find on google about webgl and changing settings. Still freezes up to the point of restarting pc. With Chrome I was able to finally get into a dronedeploy pre-loaded map after several attempts and restarts. Clicked on the little cube in the bottom left and opened up in sketchfab. Kept getting errors that webgl had an error and needed to be reloaded. Did this several times and was finally able to see the 3d stuff and move it around! Then I would get an error about display driver stopped responding and has recovered. Could it possibly just be I need to upgrade my graphics card? This is becoming very frustrating at this point. I really do appreciate all the help you guys have given so far!


#13

Updating your GPU driver might help, but I'm skeptical.

Your system has a TON of memory (18 GB RAM) but your GPU has only 512 MB VRAM. Your machine should be able to allocate RAM as VRAM, but this is dark magic that I don't understand.

@paul_sketch do you have any advice?


(Hawkeye1) #14

I've also noticed I can't view 4K videos anymore as well!


(Paul Sketch) #15

Going for a better GPU is definitly the way to solve all those problem at once.
8 year old gpu is not going to behave well... even the low priced nvidia gt710 with 2gb vram will solve the problem.

Otherwise:
- make sure disable/uninstall those "cyberlink" and "vnc" "drivers": they are slowing down and making the pc instable (and they're probably not needed, vnc runs fine withoutn and cyberlink is for screen recording, other utilities record screen without those OS intrusion.)

  • as suggestd by pauljs75 you can use also the HD/SD texture switch and choose LD whenever possible.

  • "4K videos" mention: if you're on highDPI screen, the GPU is definitly not sufficent, for a 4K screen you NEED a GPU with at least 1.5Gb. Another way is to render at lower resolution on those 4K screen with url Option "?overrideDevicePixelRatio=1". if you're on highdpi screen, you definitly need a mucher higher class HW GPU...


(Hawkeye1) #16

Thank you so much for the help/info!! I've been wanting to upgrade the GPU anyway so this gives me a good excuse to do so.


(Josepharmour) #17

Hello friends, I’m suddenly unable to view any model in 3D (including all of the ones in debug resources) on sketchfab using Chrome, I can however view them using Firefox. I cant seem to find a fix that works, so now im here :smiley:


#18

Hello,

Can you please send me a screenshot of this report from Chrome?

http://webglreport.com/


(Josepharmour) #19


#20

Google SwiftShader is not currently supported for performance reasons. You can read some discussion here: Troubles with webgl