3DS MAX plugin, exporter error


(Guiguimbop) #1

The 3dsmax exporter from Mr Klaas is very impressive (with uv and bake functions).
I downloaded a free version of 3ds max 2018 to try.
After having a first error about the Arnold render, i change the render setup to scanline (arnold seems to replace mental ray).
The error was replaced by a “maxscript rollout handler exception : runtime error : actively linked objects cannot be collapsed”.

So i removed the unwrap and bake’s functions, and just try to export a simple cube. The most basic way to export from the plugin.
Now i’ve got this error message (image below).

How can i fixe this ? Is it about 2018, somthing else, or am i just unlucky…?
Thanks


#2

Hmm, I have not seen this error before. Maybe @klaasnienhuis can help.

Are there any additional details in the MAXScript Listener window?


(Klaasnienhuis) #3

You could indeed post the contents of the maxscript listener here (press F11 to open it). And you can also look for the filepath mentioned in the error popup. Does the file exist, or is that folder empty?


(Guiguimbop) #4

Thanks a lot for the answers.
I add the screenshot of the Maxscrip Listener Windows.
The filepath mentioned not contain the zip file, only the max file and the fbx file.
Maybe the problem come from the 2018 trial version ?


(Klaasnienhuis) #5

Trial version or not shouldn’t make any difference.
Could you check if a certain file exists? It lives in your 3dsMax installation directory, something like C:\Program Files\Autodesk\3ds Max 2018. Look for the file maxzip.exe. That’s the program I use to zip the model and textures before uploading them. It seems that the model is correctly exported (the fbx is there) bu tthe zipfile isn’t created.


(Guiguimbop) #6

It’s seems that i got the maxzip.exe file.
I reinstall the program but same problem.
Maybe i can replace the file with an other one ?
Just in case, i open directly this .exe file and it’s said “incorrec number of arguments for maxzip”.
Thanks for to follow my case


(Guiguimbop) #7

I re-install the program a third time in english (instead of french) and it’s working…Sorry for the disturb and thanks for your product


#8

Hmm that’s interesting. @klaasnienhuis Could the language be messing up the paths the plugin looks for?


(Klaasnienhuis) #9

Thanks for getting back to me. Still, it’s kind of disturbing a language version causes this. I’ll have to investigate this myself.


(Klaasnienhuis) #10

I’ll have to see. I see in the screenshot the ENU (english us) language is used, but the tool doesn’t actively use a certain language. 3dsMax should provide the correct path regardless.


(Guiguimbop) #11

Same error as the first time with same error message ("maxzip error, impossible to open the file of the file’s list %s)
I deleted all my autodesk programs (maya LT and old version of 3dsmax2017, exept REVIT LT) and everything works again on the first time i open 3dsmax.
I close 3dsmax and one again the export crash when i try to use sketchfab exporter.
I guess something is corrupted betwin the time i close the 3dsmax’s first session to the time i reopen it.

At least, uninstall and install everything, every time, is a kind of solution…
I ask to autodesk to get a 2017 version of 3dsmax but it’s seems complicated.

maxz


(Guiguimbop) #12

I directly ask to the maxzip developer, but seems that the email adress is not valid.
Anyway, do know how to replace the maxzip files if they are corrupted at a moment ?
Thanks


(Guiguimbop) #13

Definitly, after a fifth installation of 3dsmax, the problem appears at the second opening of 3dsmax.
It has nothing to do with the language, but a modification of maxzip when 3dsmax close for the first time, or when it opens at the second time.


(Guiguimbop) #14

I can close the topic now.
The solution i found is to reinstall windows and i’ve no problems anymore.
It’s like kick the tv when it broadcast badly… but it’s a solution.
Sorry for the disturb