A Fix for the n-gon problem?


(Ndrakey) #1

Hey guys, will there be a fix for the n-gon problem anytime in the future? I personally like n-gons, they keep the object size small. Wouldnt make sense to add more geometry in my oppinion.


(Simon Kratz) #2

Hi ndrakey!
Can you tell a bit more about what the problem is?
Internally every 3D model is composed of tris, no matter in which application.
In some applications like 3ds max you can force a certain triangulation for each n-gon separately but I'm not sure if Sketchfab or the fbx exporter stores this information.
Filesize of 3d models aline though is rarely a problem so I guess if it improves the final quality I'd just add the extra edges :slight_smile:


(Ndrakey) #3

Hi Simon!
Ich meine den Text, der in die "Plattform" eingearbeitet ist. Der Aufwand erscheint mir doch ziemlich gro├č. W├╝rde ich willk├╝rlich triangulieren, k├Ânnte man das Objekt danach auch wegschmei├čen. Manuell polygone hinzuf├╝gen dauert ewig.


(Simon Kratz) #4

Ah I see! Couldn't preview it on my phone but now I'm on PC and I see the problem :smiley:
Did you check if the exported model has the issues, too? It would be interesting to see if the problem is an export issue or on Sketchfab's side.

(I'll continue talking english so that the support can follow this discussion, too :slight_smile: )


(Shaderbytes) #5

@essimoon @ndrakey I have found most of the time sketchfab triagulates N-Gons without any problem. Only once or twice did I notice something went wrong. Some time ago the wireframe view on sketchfab must have being updated because it actually shows N-gons properly. (without the triangulation) .


(Mrchlblng) #6

Hey @ndrakey, @essimoon,

we're aware that our polygon tesselator is far from great. We have a bunch of complaints typically regarding the way text is triangulated every other week or so.
One idea would be to remplace our tesselator by the one used in blender (which seems to often do a better job) but as it's not a big priority as softwares usually have options to export triangulated meshes.
So we'll improve this eventually but we do not have any ETA for now.


(Mrchlblng) #7

@shaderbytes we always try to show the correct topology in the wireframe. If you have an example where the wireframe is showing the tesselated, please tell us; it might be the case that some extensions get tesselated too early in our pipe and prevent us from computing the real wireframe. This a bug that should be fixed!


(Shaderbytes) #8

It was a while ago and I cant be sure of how the model was exported/imported (formats etc) but I will keep an eye out for it if I see it again and let you know.


#9

Convex curves should tesselate ok, but concave not so much.


(Simon Kratz) #10

Still glad it works for you now! :slight_smile:
Maybe we'll even see an outmated solution in the future!


(Ndrakey) #11

it doesnt really work. I just used the "random" triangulation" function. It basically destroys the the shape. Most of the surface is flat though. I just checked that this is not caused by overlapping edges. My app still displays everything properly. So it must be a Sketchfab issue. See here:


(Shaderbytes) #12

I would not leave this kind of ngon conversion to an automated tool anyway since you are bound to get long thin triangles which never play nice with lighting due to the smoothing performed by shaders across edges. What app are you referring to? Your 3D modeling application?

Personally when I use N-Gons I only use simple structures where I know the conversion would be trivial to any algorithm , I know it wont generate long thin triangles and never on anything non planar.


(Gistold) #13

Hey here, maybe, try two thing :
1.http://www.scriptspot.com/3ds-max/mcg/inset-chamfer (if it's plane surface)
or
2.http://polycount.com/discussion/168610/proboolean-dynamesh-hardsurface-workflow-tutorial (if it's not a plane surface, but work with plane surface)
hope I helped you !
hf