Sketchfab Forum

Adding a Scale Bar


(Mcurry) #1


Is there a way to add a scale bar to a model? I am uploading scans of museum specimens and a scale bar is needed for proper display.

Is there any way to do this?



Hi Michael,

We don't have measurement tools yet, but it's a common request and something we want to implement in the future. I'll add your '+1' to this feature request.


(Mcurry) #3

Great, thanks. Measurement tools would be ideal, but even a "floating" 3D scale bar would be great.

Any suggestions how I could create one to upload with my model?

(Dark Minaz) #4

create plane, add sort of a ruler texture
that would work

(Mauricesvay) #5

@mcurry Hi, we've made an experimental measuring tool:

Hope that helps.

(Theovasilis) #6

+1 on the scalebar feature

(Mariannegoudriaan) #7


Is it possible to add meters in this feature?


(Mauricesvay) #8

@theovasilis how would the scalebar work?

(Mauricesvay) #9

@mariannegoudriaan how do you imagine it should work?

(Theovasilis) #10

To set the scale you use a line tool when setting up the model(now in the be tab) You measure a dimension in your object and set the right size and units. Then a bar is generated and positioned in one corner of the screen. It is locked to the view. Due to perspective it is not accurate for all points of the object but it gives you a sense, bit like Google maps. If you wish you can add the measurement tool to the GUI for viewing objects too. Thank you for your time.

(Mauricesvay) #11

You mean real life units, like meters or inches, right?

(Theovasilis) #12

Yes, as you said.

(Mariannegoudriaan) #13

@mauricesvay and @theovasilis, thanks for answering! Sorry for my english, it is not that often used.

Unfortunately I don't understand the reference to the "be tab" where I could find a line tool with a generated scale bar? PRO option perhaps? Can you show me a screenshot perhaps, if that is not too much trouble?

I make my models in SketchUp. It is properly dimensioned (in centimeters). I upload it and then the only thing I can find with some sort of resizing (to the world) is the virtual reality tab in my 3d settings option which I used to make it fit for 3d viewing glasses. When I scale my model to 39 it looks normal to the character (1 centimeter = 0.3937 inches).

But perhaps I can't have both: it is either correct measurement in that tool or 3d? I thought at first it kept my modelmeasurements no matter what.

When I use the measurementtool mentioned in this topic it is measuring my model in (the correct) inches instead of meters:!/models/612aaa36b8a9428bb4e5f27f37f8df3e

This model is measuring correctly in meters, so it seems:!/models/c44b9a3f4a6d4e5f8e3fbabf1f179b54

I can't find other options in the 3d settings tool such as the generated bar nor an option for setting the units.
I would like to be able to setup something like the dimension tool in SketchUp but I can't import the dimensionlines this way.

Doing something with the GUI? Perhaps on a website with the model embedded is perhaps a possibility but beyond my comprehension in short notice.

Sorry again for not understanding it all, I thought it was a possible future feature for all accounts perhaps to come. So other people looking at my model can easily see the correct dimensions.

(Mauricesvay) #14

Hello @mariannegoudriaan,

I think I need to clarify a few things on measurement on Sketchfab.

  • Sketchfab doesn't support real-life units at the moment. When model are uploaded to Sketchfab, only "raw units" are used. The real-life scale isn't imported.
  • There is no tool for adding a scale bar yet, not even for Pro accounts.
  • We currently have a way to set the scale factor for VR. The UI doesn't allow for very accurate measurements, but it is easy to use. You can compare your model scale to a reference human (1.75m tall), or a floor tile (1x1m). This scale is only used in VR rendering at the moment.
  • Like many others in the VR industry, we recommend using 1 unit = 1 meter.
  • The "Measurement" experiment only uses the raw units, and doesn't take the VR scale into account. However, you can set your own factor there to convert units into something else.
  • If you need a scale bar, the best for now is to include it as an object in your model, like on

(Mariannegoudriaan) #15

@MauricesVay, thanks for clarifying.

If I use scale 39.37 it is measured correctly with the tool (in inches). So I was puzzled because it was saying unitless in that tool but nevertheless in inches correct but the 3d settings is mentioning meters.

For my model working almost just fine.:sunglasses:

59.05 is 1,5 meter

I will consider using other options for showing a scalebar in the model!


(Mauricesvay) #16

Your software is probably exporting models as 1 unit = 1 inch in that case.

In the "Measurement" tool, you can just set the conversion factor to 0.0254 to get the measurement in meter.

(Mariannegoudriaan) #17

@MauricesVay, I didn't expected SketchUp exports models, that are made in meters, in inches (with .dae). But some googling suggests it really could be the case that SketchUp is doing it that way. And after trying out a cube of a meter which I scaled in Sketchup to 0.0254 meter, SketchFab is showing it as 1 meter.

On the left the cube in 1 meter with the original SketchUp male and on the right the cube I resized to 0.0254. I can use scale 1 in Virtual Reality tab when I resize to 0.0254 (meter in SketchUp).!/models/1bf18f47a7ec4c9d97b05994e4dafabe

I understand I, myself, can convert the inches to meters, which I already did, or the otherway around. But I don't want to expect that from others to multiply (convert), then I should explain to them what to do with my model somewhere, which makes it more trouble for others to easily see the measurements, while text information over the model isn't in the measurement tool also.

I will just have to wait till there comes another way or have to add some scale in other ways like 3d text or with a plan added.

If I want to show my models in units from a meter with 1x in the measurement tool, I can always, as another option, scale my models to 0.0254... but there would still be the problem the other way around.

Thanks for delving into my problem/question!