Adding Texture Only Changes Color of Material

materials
sketchup
textures

(Plae) #1

I model in SketchUp 2017. When I upload my model to Sketchfab and try to add textures in the 3D Editor, all that changes is the color of the material in question (e.g., I drag/drop grasstexture.jpg from my desktop, but all that happens is that my material turns green - no bitmap effect).

I've tried applying textures within SU 2017 before uploading to Sketchfab, but no luck there either. I've also tried dragging/dropping to bump maps, etc., just to see if that would work. Nothing does.

Eventually, I'd like to be able to export AO maps, bump maps, textures, etc. from SU to achieve a nice, shaded, realistic look for my models. Can anyone help?


(Dark Minaz) #2

how does your uv look like?
that would help to see why the texture won't load.


(Plae) #3

Regarding UV, I'm not sure. I'm relatively new to modeling and have just been using SU's Sketchfab upload plugin. Is there a step I'm missing to make sure my UV is unwrapped and ready to go when uploading a model from Sketchup? Thank you for your help!


(Dark Minaz) #4

A uv is to explain it simply a map on where to put the texture on the 3d object.
IT could be that there is some sort of automatic uv but you would have to search for that in the internet a bit for a tutorial

https://extensions.sketchup.com/en/content/sketchuv
sounds like the simplest way to create one, but i don't use sketchup.
Normally you probably just use colors, sketchfab can ignore a uv at that point as it just fills everything with that color
but if you add a texture it needs to know where to put those things :slight_smile:


(Plae) #5

Okay, I'll look into it. Thanks again!