Agisoft Photoscan Direct Upload issue - 'Error creating SSL'


(Hugo Anderson-Whymark) #1

Hello, I've been working on a new computer and I hit an error every time I attempt a direct upload from Agisoft Photoscan to sketchfab. In each case the model goes through the 'packaging' stage and then immediately pings back the error message 'Error creating SSL Context 0'. The detailed info simple states 'Response Code: 0'.

I'm sure it's probably some setting on my new machine, but I'm struggling to find a solution and I wondered if anyone had any thoughts?

Thanks Hugo

I


#2

Hmm. What version of PhotoScan are you using?


(Hugo Anderson-Whymark) #3

Hi, I'm using Photoscan Standard edition v.1.3.2.4205 (the most recent). I ran an update from the previous iteration this morning, but still have the same issue.

Any help is greatly appreciated!

Hugo


#4

Thanks Hugo,

I just tested the same version here and it worked. Could you close everything, maybe even restart the whole machine, and check the API Token?


(Hugo Anderson-Whymark) #5

Hi James,

I've fully rebooted the machine and reset the API Token and I'm still getting the same error message. I'm not sure what to try next...

Hugo


(Hugo Anderson-Whymark) #6

Hi James, I managed to find the cause of the problem - a couple of missing OpenSSL .dll files. All installed now and just running a test upload - all looks find. Thanks for your help.


#7

Glad you got it working! Thanks for letting me know.


(Fof Sedona) #8

I have the same problem since updating Photoscan. Can you please provide some additional detailed information on which DLL files so I can potentially download and install them
Thanks


(Hugo Anderson-Whymark) #9

Hi,

A quick reply as I'm on my way out the door...

The .dll files I used were downloaded here - Win 32 OpenSSL - http://slproweb.com/products/Win32OpenSSL.html

If you open the zipped download you can find the following files:

libeay32.dll
ssleay32.dll

You need to add these to your registry and the issue should be resolved.

Hope that works for you!

Hugo


(Lafoto) #10

I am having the same problema here.
Somebody have a solution?


(Hfenton) #11

I have the same problem trying to upload from Agisoft Photoscan to Sketchfab (Windows 8.1)

'Error creating SSL Context ()' 'Response code:0'

with the current PhotoScan Standard edition v.1.3.2.4205 (and the previous v.1.3.1.4030).

I have tried the above and not managed to resolve the problem

I'm unsure whether this is a Sketchfab problem or Photoscan Problem or to do with how my computer is set up, my computer isn't new - I have previously used Photoscan to upload over a hundred models to Sketchfab without issue.

Any thoughts and/or help to resolve the issue would be great.


(Hugo Anderson-Whymark) #12

Hi Hamish,

The problem was sorted on my computer (windows 10) as soon as I manually added the .dll files to the registry. Just installing the openssl32 did not work for me if I remember correctly.

Hugo


(Hfenton) #13

So how or where should I mess with the registry?
I have tried manually adding the both dll using regsvr32 but it throws the following error:

The module "ssleay32.dll" was loaded but the entry-point DllRegisterServer was not found.
Make sure that "ssleay32.dll" is a valid DLL or OCX file then try again.


(Ara) #14

I'm having the same issue. Where in the registry do these dll files go? Do I use the stated 32.dll files or do I use 64.dll files since my PC is 64 bit?


(Rockdoc) #15

New user here, and encountered the same "error 0" as others on my very first model that failed to upload from inside Photoscan to Sketchfab account.

Need specific information as requested below by others.

Hugoandersonwhymark or STAFF: Would really appreciate your filling out the last few steps of your successful resolution on a Windows 10 system. Could you just bullet point the steps you took for "adding the .dll files to the registry"?

Thanks much.


#16

@rockdoc @ara I'm afraid I haven't been able to reproduce this issue on our machines, so I'm not sure on the details of installing the openssl DLL

@hugoandersonwhymark could you elaborate on the process for us? Much appreciated!!


(Rockdoc) #17

How about this - even without reproducing the error, can you provide step-by-step instructions for installing an openssl DLL? Thanks.


#18

I guess I misspoke. I don't know how to do that, sorry :frowning:


(Hugo Anderson-Whymark) #19

Hi Hamish, Rockdoc, Ara and James,

Sorry for the delay getting back to you. I'll put a disclaimer here as I'm not a tech whizz and I solved my issue via a series of Googles and tinkering. I've rechecked what I did at the end, so here so goes:

As I said previously, just installing Win32OpenSSL did not seem to work for me so I manually added the .sll files by:

  1. Opening the Win32OpenSSL zip file.
  2. Copying the .dll files (libeay32.dll and ssleay32.dll)
  3. Pasted these in the following locations: Windows C:/Windows/system32 and Windows C:/Windows/sysWOW64

I immediately tested an upload and the issue was fixed. I can't say if there's a better way of doing this, but I've had not issues as a result.

I hope this works for you.


(Rockdoc) #20

Thanks for the additional information, Hugoandersonwhymark. Just two more clarifications would be helpful.
1) At the Win32OpenSSL web page, there are two versions of installers, 1.1.0 and 1.0.2. Could you identify the version you used for the two DLL files?

2) Both versions are distributed as EXEs. I don't see a ZIP archive for distribution. Did you run the EXE, or perhaps access a ZIP file at another location?

Thanks a bunch.