Agisoft Photoscan Direct Upload issue - 'Error creating SSL'

Hi. I downloaded and ran v.1.1.0 of Win32OpenSSL. As I said before, just running this .exe did not solve the problem for me, so I located the .zip file in downloads and manually copied and pasted the .dll files into the windows folders detailed above.

1 Like

Thanks to Hugoandersonwhymark and others for all the necessary information I needed to successfully complete an upload to my Sketchfab account. Here’s what worked for me.

  1. system config: Windows 10 Pro
  2. As directed, visit: https://slproweb.com/products/Win32OpenSSL.html
  3. Download: Win32 OpenSSL v1.0.2L Light (4th from the bottom, 2 MB installer). The downloaded file in an EXE.
  4. Before running the EXE, I set a SYSTEM RESTORE point, just in case.
  5. Before running the EXE, I confirmed with a SEARCH in /Windows/ for libeay.dll and ssleay.dll that these two files were not installed. Confirmed absent.
  6. Double-clicked the EXE file: Win32OpenSSL_Light-1_0_2L
  7. With SEARCH I confirmed that the two dlls were installed. On my system, these files were placed in /Windows/sysWOW64 folder. I did not have to move these files to a different location.
  8. In browser opened my account at Sketchfab.com
  9. Clicked the UPLOAD button, upper left corner of window.
  10. Navigated to the folder MODEL, double-clicked “model”
  11. Photoscan recognizes the presence of the doc.XML, mesh.PLY, and texture.PNG files, and
    12 UPLOAD proceeds without error.

Hope this help anyone else with a similar system.

2 Likes

I had to use the Win64 OpenSSL v1.0.2L Light 3MB downloader but just ran the exe and it worked.

I have two left thumbs and am a dumbarse under the computer bonnet but it just worked having tried all the other steps above

hope this helps

cheers

bob

1 Like

The method described by HaltonCharters worked for me as well.

1 Like

I think I’ve figured out what is going on here.

I have a laptop that worked fine when it came to posting models to Sketchfab. I then tried from my desktop and no joy. OpenSSL was already installed on the Desktop by another app. I tried downloading the latest version of OpenSSL thinking that it would be the most up to date and therefore most likely to have any bugs fixed.

Both machines are 64bit and downloading the 32 bit as someone suggested above didn’t help. Photoscan is most definitely a 64 bit app!

Turns out when I downloaded and installed the specific version “Win64 OpenSSL v1.0.2m Light”
available here…

http://slproweb.com/download/Win64OpenSSL_Light-1_0_2m.exe

did it work. No need to mess with the registry.

I believe that the issue is the Photoscan has been compiled to work with the specific version of OpenSSL and many machines have a more recent version of OpenSSL. Hopefully Agisoft will see this post and fix it going forward to use the a no specific version of OpenSSL.

1 Like

I have the same problem but,
the directory slproweb.-Win64OpenSSL_Light-1_0_2m. exe no longer exists.
someone can tell me how I can do ?

however, the new error message is: SSL support not available.

Tnks

I had the same problem, Windows 7 Ultimate 64.

Assumed downloading the latest Open SLL version would be best

Nope, didn’t work

downloaded the 64 bit version suggested by BjFae Torphins above, and it worked fine.

Didn’t even need to reboot or even close anything running

1 Like

I’ll preface with I am a very novice user of both PhotoScan and sketcfab. I’m trying to upload a model using the Sketchfab API key in Photoscan, but get the error “SSL support not available.”

I have been successful in the past using an older version of Photoscan. Currently, I’m using Agisoft PhotoScan Professional version 1.4

-Crystal Heis
Special Collections Research Center
University of Kentucky

Hi @UofK_digital_lab !

It seems that you need to install OpenSSL on PhotoScan. You can read more about the issue in PhotoScan’s forum:
https://www.agisoft.com/forum/index.php?topic=8355.0

Hope this helps. Feel free to ask any follow up questions.

Cheers,

Thank you. I had seen that thread but my error message was slightly different than the one described. So, I wanted to double check.

Packages for PhotoScan that need to use secure connections (https) need you to install OpenSSL. For example, mapbox presents the same issue you described:

https://www.agisoft.com/forum/index.php?topic=4515.0

The solution consists of installing OpenSSL which is described in more detail in the post I shared before. If you still have issues after installing it, feel free to post some follow up questions.

1 Like

Thanks. I installed the OpenSSL and everything is working. I appreciate the follow-up.

1 Like

Hello there, I have tried installing but I still have the same message… Any other suggestion? It used to work just fine on my other machines…
image

1 Like

The error still persist after installing the Open SSL Library.
Please any suggestion?