Alembic animation stuck in Static Pose

I have a problem with an Alembic animation.

I uploaded a test file with a single alembic animation: I can see it correctly in the web viewer, but when I download the usdz version and try it using my iPhone, the model is stuck in static pose.

I also noticed that every time I enter the 3D settings, the static pose is automatically set as the default pose, although I have flagged my animation and saved the settings.

I don’t understand if the problem is related to Alambic itself (that maybe is not supported in usdz and gltf files) or it is more related to an issue with the animation settings of sketchfab.

Does anyone had a similar problem or have suggestion?

Thank you in advance

Hi @forgereply,

The Editor fallbacking to Static Pose is not related to your issue. I don’t remember why it’s like this, it’s maybe a bug I’ll check.

Your main issue is caused by morph animations not being currently supported by Apple AR viewer, so they are not exported in USDZ. If you download the glTF and open it in an external glTF viewer such as this one you will get the animation working as expected.

Only solid (transform) and skinning animation are supported in USDZ (Apple AR) at the moment


Thank you @waleguene for your reply.

I searched over the net but I didn’t find a clear answer about Apple AR viewer and Alambic animation till now.

I’ll be waiting for the resolution of the fallback problem in the editor.

1 Like