Alembic from Blender


(Gilles38) #1

Hello,
I am testing the Alembic export for animations from Blender latest version (2.79). I am surprised by the reflection of light in Alembic format in Sketchfab on this simple plane:

I don't want this reflection and I don't see it in COLLADA format for instance (see below). But I can't figure how to change this when using Alembic. Did I miss something about the Alembic format ? Or is this expected ?

Here is the very same plane exported as .dae (COLLADA)

Here are the Alembic presets I used in Blender:

Thank you for your help


(Bart) #2

I'm not too familiar with Collada exports from Blender, but this should be easy to fix in our 3D editor:


(Gilles38) #3

Hi Bart,
Yes I can fix the lights for collada models but my point is just the opposite: how to change the lights on this plane for Alembic format. I haven't been successful yet.
Changing lights has few consequences and shadows are strange depending on the angle while on collada or obj everything is fine.
Thank you


(Bart) #4

Ah I see. It would be good to know if the issue is in Blender's exporter, or our importer. Did you try loading both files into other software to compare?


(Mrchlblng) #5

@gilles38 I think this is just a matter of environment. It seems that gareoult brings too much light in the alembic scene. So you could either diminish the brightness or change the environment and possibly use foodprint court as in the collada sample.
Note that only the environment orientation can be changed by (power) user in the viewer.
And as a side note, we do not import lights from alembic models yet.


(Gilles38) #6

Hello @mrchlblng,
thank you for the reply.
Shame on me, I forgot to turn Environment OFF !
Now it is OFF on both models, I have moved all lights to the center, and Roughness/Glossiness is at 0 (is it the same as brigtness?)
Just as a additional note in case it is important, the Alembic file is an animation (but seen as static in the pictures below), Collada is not.

Here what I get:
Alembic:

Collada:

What do you think?
Thank


(Gilles38) #7

Hi @bartv,
No, I am using Blender only so far...


(Mrchlblng) #8

@gilles38 I think your current issue is that the "direction" lights you add are "Attached to camera" so the shading will depend on the camera position.
This is our default setting currently and we might change this in the future. If you disable the "Attached to camera" setting, I believe you'll have the result you expect.


(Gilles38) #9

@mrchlblng,
well that doesn't explain why the two models don't perform similarly as the light settings were identical in both cases.
Coming back to the default "3 lights" setting, here is below what I have with both models and lights "Attached to camera" ON or OFF. The results seem to be identical, in my opinion.
A) with all 3 "Attached to camera" ON
Alembic:

Collada:

B) with all 3 "Attached to camera" OFF
Alembic:

Collada:

So lights don't seem to be the main reason for these differences, don't you think?
Or maybe I misunderstand something...


#11

@mrchlblng maybe the issue is from different normals caused by quads in the alembic vs tris in the collada?


(Gilles38) #12

Hi @james,
Good observation. I have exported from Blender with the Triangulate option.

This option offers so called "Quad M" and "Polygon" options, each with 4 possibilities shown here

(so 16 possibilities total). and I have used only the default ones shown in my first picture above
At the end I see no differences with or without triangulation.
But how do you see the normals in the Sketchfab settings ? Didn't find that.

Alembic with triangulation:


#13

Admin 3D debug tools :innocent:

Some things will be available to general users soon with the Inspector:

https://blog.sketchfab.com/siggraph-reveals-subsurface-scattering-scene-inspector/

Looks like your version exported with no normals fixed it. We re-calculate them during processing and they look more like the collada normals.


(Gilles38) #14

Yes !
Great @james. Indeed the "No Normals" option fixed it !
Regardless of triangulation.
Thanks a lot !
And yes it will be great to see the normals in the 3D editor.