All models fail to complete loading in Chrome


(Sd1) #1

This is a recurring problem with Sketchfab on Chrome to the point where it has become unreliable for me.

The models were working in Chrome about two days ago when I last logged in.

The loading bar gets to 100% and stays there. Nothing happens after that.

The models load in Firefox but Chrome is my preferred browser.


(Rémy Bouquet) #2

Hello, I'm sorry to hear that. Could you please give a link to the problematic scene?


(Sd1) #3

All scenes are problematic...nothing loads. Site wide.


(Rémy Bouquet) #4

Alright, so let's try to understand what's going on. We didn't notice any major issue like this on chrome, so maybe something is wrong on your end.

Could you please check your chrome extensions, to see if one of them is not problematic so that we investigate?


(Sd1) #5

I disabled WebVR API extension and everything works now.

Not sure where it came from or why Sketchfab was working when it was enabled.

Thanks for your patience & assistance.


(Rémy Bouquet) #6

I think we already had issues with this extension, we are going to check that out.
Thank You.


(Aleahy) #8

Just got bitten by the same thing.

Disabling the 'WebVR API Emulation' (1.1.4) extension fixed it.

Chrome Console log:

viewer-76140d2038504a321f47.js:18 osgjs.metric:ReaderParser.parseSceneGraph: 8.200927734375ms
commons-c0e4ce2520c45ac9e029.js:25 Unhandled rejection TypeError: Cannot assign to read only property 'pose' of object '#<VRFrameData>'
    at <anonymous>:284:19
    at VRDisplay.getFrameData (<anonymous>:409:10)
    at N.r.a.a.extend.onWorldFactor (https://d1jlf623bx36qa.cloudfront.net/static/builds/web/dist/viewer-76140d2038504a321f47.js:23:1481925)
    at y (https://d1jlf623bx36qa.cloudfront.net/static/builds/web/dist/commons-c0e4ce2520c45ac9e029.js:25:100112)
    at m (https://d1jlf623bx36qa.cloudfront.net/static/builds/web/dist/commons-c0e4ce2520c45ac9e029.js:25:99786)
    at h (https://d1jlf623bx36qa.cloudfront.net/static/builds/web/dist/commons-c0e4ce2520c45ac9e029.js:25:97738)
    at N.r.l.trigger (https://d1jlf623bx36qa.cloudfront.net/static/builds/web/dist/commons-c0e4ce2520c45ac9e029.js:25:99679)
    at N.r.set (https://d1jlf623bx36qa.cloudfront.net/static/builds/web/dist/commons-c0e4ce2520c45ac9e029.js:25:101543)
    at N.r.initAfterFirstFrame (https://d1jlf623bx36qa.cloudfront.net/static/builds/web/dist/viewer-76140d2038504a321f47.js:23:1439515)
    at A.finished (https://d1jlf623bx36qa.cloudfront.net/static/builds/web/dist/viewer-76140d2038504a321f47.js:23:1033120)
    at N.r.featureFinished (https://d1jlf623bx36qa.cloudfront.net/static/builds/web/dist/viewer-76140d2038504a321f47.js:23:582315)
    at N.r._launchViewer (https://d1jlf623bx36qa.cloudfront.net/static/builds/web/dist/viewer-76140d2038504a321f47.js:23:580259)
    at i (https://d1jlf623bx36qa.cloudfront.net/static/builds/web/dist/commons-c0e4ce2520c45ac9e029.js:25:63426)
    at e._settlePromiseFromHandler (https://d1jlf623bx36qa.cloudfront.net/static/builds/web/dist/commons-c0e4ce2520c45ac9e029.js:25:36830)
    at e._settlePromiseAt (https://d1jlf623bx36qa.cloudfront.net/static/builds/web/dist/commons-c0e4ce2520c45ac9e029.js:25:38099)
    at e._settlePromises (https://d1jlf623bx36qa.cloudfront.net/static/builds/web/dist/commons-c0e4ce2520c45ac9e029.js:25:39957)
    at r._drainQueue (https://d1jlf623bx36qa.cloudfront.net/static/builds/web/dist/commons-c0e4ce2520c45ac9e029.js:25:2929)
    at r._drainQueues (https://d1jlf623bx36qa.cloudfront.net/static/builds/web/dist/commons-c0e4ce2520c45ac9e029.js:25:2990)
    at MutationObserver.drainQueues (https://d1jlf623bx36qa.cloudfront.net/static/builds/web/dist/commons-c0e4ce2520c45ac9e029.js:25:932)