Allowfullscreen on mobile - problem

mobile
3d

(Empe2301) #1

Hi, I have problem with display iframe on mobile - I have no possibility to see 3d at full screen. On desktop everything is ok, but on mobile I can't see an icon that enables full screen.

<iframe ng-src="[[videoUrlYoutube]]" frameborder="0" allowfullscreen class="event-effect"></iframe>

Where is the problem? Thanks.


(Mauricesvay) #2

@empe2301 I'm sorry, but we can only provide support for Sketchfab viewer. For Youtube related questions, you should ask Youtube.


(Empe2301) #3

Omg, i'm sorry, I pasted wrong code, because I have in one place movies and 3d, sorry. This problem is with sketchfab viewer, not Youtube, and my code looks like:

 <iframe src="" id="api-frame" allowfullscreen mozallowfullscreen="true" webkitallowfullscreen="true"></iframe>

#4

Are you on iOS? I think iOS does not support the native allowfullscreen iframe attribute. We fake it with a direct link the the /embed page.

However, if the button is missing completely, there could be an issue. Can you share a link to the site so I can take a closer look?


(Empe2301) #5

Thanks, james.

Yes, I actually use iOS and I only tested it on this system. So you say that on the Android it works? Unfortunately, I do not currently have the ability to test this on the Android.

Below is link to Codepen with my example. Thanks with any tip.


#6

You have ui_controls disabled in your initialization options. This will hide all the controls in the bottom right. If you want to keep the fullscreen button while hiding the other controls, you'll need to use the more explicit embed options. See:

I did not investigate this, but there could also be some side effects of embedding our iframe inside a Codepen iframe, depending on their sandboxing policy.


(Empe2301) #7

Ok, but are You suggesting that when I change ui_controls from 0 to 1, button should be visible also on iOS? Because I changed this and now my iframe in inspector looks like:

<iframe src="https://sketchfab.com/models/e27289dc4cf247119a5a6798f4f2f812/embed?api_version=1.0.0&amp;api_id=547777971942182&amp;internal=0&amp;ui_infos=0&amp;ui_controls=1&amp;watermark=1&amp;continuous_render=0&amp;supersample=0&amp;camera=0" id="api-frame" allowfullscreen="" mozallowfullscreen="true" webkitallowfullscreen="true"></iframe>

but stil button isn't visible on iOS.

So i want to know if i can see this button on iOS and now i'm still doing something wrong (ie i should test it not on codepen) or is it impossible to get at all on iOS? :slight_smile: Thanks!


#8

It should work on iOS. If you can send me a link to a live test (Codepen or otherwise) I'll take another look.


(Empe2301) #9

Yes, I updated codepen, code is here:


#10

Hmm, is still has ui_controls: 0 ?


(Empe2301) #11

Yes, but I was thinking that when I set ui_controls here
document.getElementById('api-frame'), onSketchfabUtilityReady, {camera: 0, ui_controls: 1});

this attribute will be overwritten. On inspector browser I can see that this value is changed:

Anyway, I changed it in on initObject and still nothing happen on iOS.

Codepen:


(Empe2301) #12

Still problem on iOS. I compare two systems at the same time and the effect is like on screenshots.
1) Android - everything looks good
2) iOS - no button allow fullscreen


#13

So there is a bug on our end for iOS, we're working on a fix. Thanks for your patience!


(Empe2301) #14

Thanks for the confirmation :slight_smile: