Sketchfab Forum

Alpha channel doesn't work anymore

transparency

(Mfhammer) #1

Beneath my models I made some shadows with a baked shadow with (alpha channel) transparency.
In edit mode it looks okay, but in view mode it's not, what has changed sketchfab?


(Madalin Berechet) #2

disable transparency: transparent: 1,
Blending transparency stopped working with transparent background.


#3

@mfhammer Yeah, it looks like we introduced a bug. Investigating! ( @stephomi )

@MadalinBerechet Sorry I'm not sure what you're talking about.


(Madalin Berechet) #4

I have a furniture model "side table" where the floor is a plane mapped using a transparent png (a baked map):

I am loading the model using initialization option: transparent: 1, and overlaying on a still image (augmented reality like)

Blending transparency, which has worked so far, doesn't work anymore.
I've tried both transparent: 0 and transparent: 1 initialization option parameters.


(Stephomi) #5

@mfhammer It's a known issue. A fix is on his way, sorry for the inconvenience.

@MadalinBerechet Can you provide an url? We can't reproduce your issue.


(Madalin Berechet) #6

this is the link

Please see on "Background" tab, where the 3d model is overlaying on a still image.
Also visible on loading (some blinks).

I am not changing that transparent map on runtime.
The map is defined in Sketchfab editor as a transparent - blending (not mask) texture (transparent png file)

Thanks.


(Stephomi) #7

I see thanks, it's another issue but it'll also be fixed on the next release.


(Mfhammer) #8

Thanks Stephomi, James for the reply, can you tell me when it's planned or when this issue is solved, for the meantime I put out all of the shadows in my models because I use sketchfab within my webshop.


(Stephomi) #9

@mfhammer Unless there is an issue, the fix should be live in a few hours.


(Stephomi) #10

Fix is live!