Alpha Ground Looks Different When Embeded on Website


(Jersied) #1

For some reason, the alpha fade that I’ve put on the ice on my model looks great on the sketchfab site, but when the model is embedded on my website it looks different/worse. Any ideas why it looks different in the two spots?

Note that on the sketchfab site I use the background within the 3D model scene, on my website the background in the 3D scene is disabled and the background for the model is embedded on my site for better responsive resizing.


(Shaderbytes) #3

Greg , there is another issue you are missing , you almost never want to do as you described because when the model background is disabled you get no AA which means all yours edges will be jaggered. This is because to do AA ( which smooths jaggered edges ) you need actual pixels around your object. When clear is used for the background there are no pixels around your object.

Honestly sketchfab needs to put a huge warning somewhere for this , you are not the first to make this mistake , actually nearly all clients that i have dealt with who embed sketchfab models in their own domain make this same choice and are unaware the model rendering is degraded because of that decision.

unless this was changed, not sure @james let us know if this is still the case


(Jersied) #4

Thanks for the heads up Shaderbytes, appreciate it. I took a close look and don’t see any issue with anti aliasing between the two options:


(Jersied) #5

Looks like I DIDN’T solve my alpha issue yesterday… it’s reared it’s head again today, I must have mistaken one of the settings. Top is with the Sketchfab background disabled, bottom is with sketchfab background enabled. Weird eh?


(Shaderbytes) #6

yeah maybe they sorted out the AA for non model related backgrounds , that is why i asked @james to share some insight for us :wink: As for the alpha glitch, a dev will have to answer you on that one … not something i personally know anything about , could be a bug.


#7

We still are not able to do AA on a transparent background.