Alpha masking - not working for me [solved (mostly)]

transparency
viewer
textures
3d

(Dark0verseer) #1

I've thoroughly read through the documentation regarding transparency. I have sets of objects, plastics, and decals/stickers, the decals are on a 2face/1poly plane which are then sized and positioned with the plastics. I have this working in 3dsmax with opacity maps just fine. When I apply the mask/opacity map in sketchfab it isn't cutting anything out, I tried playing with the threshold and inverting but not the result I'm looking for. This should be fairly straight forward so I'm not sure what the issue is.

Any help would be appreciated thanks.


#2

Hi there,

I'm sorry you're having trouble. Can you post a link to an example model so we can take a closer look?

Thanks!


(Dark0verseer) #3

Can you view a draft?


#4

Yep, looking now!


#5

I see a ton of grey objects with no textures applied at all. Can you point me to a specific object and its material name and alpha texture?


(Dark0verseer) #6

21- turntable, I just put the maps back on it. 'Gilligans_Plastic2b_O.png" is the mask map.
Or you can try 'ProfessorPlasticDecal"


(Dark0verseer) #7

Any developments?


#8

Hmm weird. I can't figure out what's gone wrong. I'll talk to the 3D team tomorrow.

cc @stephomi


(Dark0verseer) #9

Aww man this is one of those times it's not good to feel special haha. My set up looks like it should work right? Like I said Alpha masking is pretty straight forward, black = invisible, white = opaque, grey semi transparent, same maps working fine in 3ds max. Thanks for looking into it for me, much appreciated.


#10

Maybe something with the PlasticCover material overlapping it? I'm really not sure, sorry :confused:


(Dark0verseer) #11

I'll try playing around with it some more. To be authentic, pinball decals are on the underside of plastics though so hopefully that isn't it.


(Dark0verseer) #12

I tried putting a decal object off to the side, but same problem.


(Dark0verseer) #13

I tried making a separate upload to see if it's an isolated issue but I have the same problem here too:

Maybe it's a browser issue or something strange? I'm using google chrome.
[edit]: I tried firefox too and same deal.


(Dark0verseer) #14

Okay I figured something out. I read through every similar issue posted on sketchfab forums I could find and found one instance where someone just used the same image as the diffuse slot with png transparency. So I try the same thing and then adjust the threshold and it works as I would expect the alpha to work, the question still remains why won't the traditional alpha work for me?


(Stephomi) #15

I don't see any drafts and the 21-turntable works fine for me on your last model.

From experience, my initial guess is that the transparency information in "Gilligans_Plastic2b_O.png" was stored in the R channel (Luminance) and not in the A (Alpha) channel.
If you upload a png, the default option is Alpha channel, if you would have uploaded a jpg, it would have been Luminance.

The browsers always assume png are RGBA texture, and we don't investigate further to check if there is really an alpha channel in the png (which can be optional, but the browsers don't tell us that directly unfortunetaly).

You can find this option in the texture selector (format : Luminance/Alpha).


(Dark0verseer) #16

Thanks for the follow-up, I think I've got it figured out now.

I published the project. :slight_smile: