Sketchfab Forum

Alpha sorting works differently in 3D settings view, and in the privately published version


(Cordero) #1

hello!

I’m working on a model which requires a lot of alpha stuff… on the glass you can see, there is an outside geometry, with an alpha attached ( these causes th reflection like things ) there is the liquid right behind that, which is inverted polygons without a backside, using alpha as well, also the top of the liquid is flipped again, facing top double sided using alpha as well, and then the inside of the glass uses another alpha.

these are not really important infos, what really is the problem, that in the 3D settings window where I edit materials, etc. the sorting works acceptable, but when I check the model like somone would see it after being published ( comments and stuff below etc.) the sorting breaks.

The whole glass and liquid is currently broken up in to individual polygons, so each polygon which makes up that area is a separate object, since after experimentation this gave the only acceptable result, but this too seams to break in the public viewer.

I plan on breaking the internet with this one, so I need to figure out a solution for this, soo a I kindly ask for help! :smiley: ( it works in 3dsmax viewport somehow )


( 3d view, with the correct sorting on right, public viewer with jumping and disappearing alphas on left )


(Paul Sketch) #2

“Blending” transparency mode require alpha Sorting, which has many quirks associated to it. (we sort by geometry, not triangles and it’s very imprecise by nature)

The difference in the viewer and editor is that we try to optimize models by minimising the number of separate geometry, in your case from 514 to 15, which then breaks the sorting
( 514 separated geom is too much for real time render, particualarly on mobiles phone)

Did you investigate using the other transparency modes, as nearly all other transparency mode doesn’t need sorting, it would fix your problem.
I would try to set dithering and mask on as much material as possible, and then enable “blending” as a last resort.


(Stephomi) #3

For information, the current threshold is 100 geometries per transparent material.


(Cordero) #4

thanks! yeah it seams additive and mask will do the trick and this time it works in the viewer too…
I guess I wont have to trash this one after all :smiley: