Animated mesh not visible

Hi there! I have a problem and I have no idea how to solve it. I made an animation in Maya, exported to fbx and uploaded here
https://sketchfab.com/3d-models/lavender-e76f84efe06441028dbb9126fa25df59

When it’s not moving it’s visible, but when you click on animation it vanishes.
I don’t know what I’m doing wrong. I tried to export fbx with the help of tutorial published here (baking animation before exporting etc.) but it didn’t solve my problem.

I’d be happy to see some suggestions!

This looks so strange, but I got some ideas.
First of all, I am not a Maya user.
WARNING, it can mess up everything, so make a copy.

Now, there is this thing in Max called xForm. It resets the transforms and scaling. There is a way to do it in Maya too. Have a go and try resetting the transforms. Also, you may need to reset it anyway and reskin the model.

I found this video, maybe it will help:
https://www.google.com/search?client=firefox-b-d&q=how+to+reset+xform+in+maya#kpvalbx=_rI4-Xub7MfCk1fAP4LW--Aw70

Thank you very much for your time!
I tried your solution but I got stuck again as I couldn’t download a free version of CheckMate Artist Inspection Tool needed (maybe I was doing something wrong again?)

But it seems I wasn’t exporting mesh properly and after few more tries I managed to make the animation work in Sketchfab.

Problem solved, thank you!

1 Like