Sketchfab Forum

Animation cycle mode to none is playing though entire animation list


(Num T) #1

Hello!

When I set the animation cycle mode to none I would expect sketchfab to play 1 take and the stop playback. What is currently happening is that it plays through all takes before stopping - is this a bug or by design? The current behaviour makes it very difficult to just play the current animation take through the viewer API unless I'm missing something...

Cheers

Jon Westlake


#2

Hello Jon!

This is the expected behavior.

One: loop the current animation
All: loop through all available animations
None: play all the available animations then stop

Please see the Help Center for more details.

For the Viewer API, you should be able to setCurrentAnimationByUID() then play() it?


(Num T) #3

Hi James

Thanks for the response! Shame that there is no way to automatically stop playback after each take. I'm currently running a main loop in my script to get round this but it is not a good way to be going about what I'm trying to do I'm sure.

Thanks for the help anyway

Cheers

Jon


(Jon Russell) #4

Hi,

Did anyone ever find a work-around for playing just a single animation only once? I would like to play individual animation on demand, but the looping is causing issues.

Jon


(Jon Russell) #5

Sorry, but I have to ask...

Did anyone ever find a work-around for playing just a single animation only once? I would like to play individual animation on demand, but the looping is causing issues.


(david_maas) #6

the design needs more options then. Might you consider adding one option:

One loop: loop the selected animation
One stop: play (and stop at end frame) the selected animation
All: loop through all available animations
None: play all the available animations then stop

This would be really invaluable for scientific / technical illustration and countless other things.


(Jon Russell) #7

Agree!