Animation imports incorrectly


(Rumen Petrov "Gumbata") #1

Hello everyone!

I just tried the animation feature and it looks awesome on my archer animations but the cavalry is going crazy. Is it something to do with the bones and helpers I use? or is my geometry messed up before the skin modifier? I use 3DS Max and my other two animated characters work fine in Sketchfab smile

This is the problem:
https://skfb.ly/GquB

This is how it is supposed to look like smile

Thanks,
Rumen Petrov


(Acornbringer) #2

Did you check to make sure none of your joints have transformations other than translate in the bind pose? Sometimes having rotation and scale transforms when you constrain your controllers can cause similar looking issues. Another thing that could be causing it is if your changed the hierarchy relationships of your controllers after keying your animation.

I work in Maya so my terminology might be off but the same principles might apply.


(Rumen Petrov "Gumbata") #3

I usually reset the scale and stretching of bones before I start animating, I also sort out the hierarchy before that and am pretty sure I havent changed it during/after animation. I am not quite sure what you mean by:

After I saw the issue I tried troubleshooting by resetting the bones and geometry again, but the import issue was the same. I even tried importing the .fbx back to 3ds max and exporting it for the second time since this was stated as a solution to some problems. The weird thing is that my other 2 characters work completely fine smiley
From what I am seeing with the Cavalry, it appears that the horse spine, ears and front leg bones are the only ones not working normal. I might have to give up on that one, even though its the prettiest frowning


(Acornbringer) #4

Yeah I can tell that animation is nice even though its all jumbled up so its a shame it's giving you trouble.

What I meant by that quote you sited is that all joints will have translate transforms relative to world space normally. It marks their position in the world (x,y,z) so you wouldn't want to remove those transformation values as apposed to the scale and rotate transforms which should be all 0,0,0 before you start rigging and animating.

Again, Maya and Max might have different terms for what I'm trying to describe but I think the principles will be the same. From what you said, it seems like you are doing all the right procedures before animating and exporting so I don't think this stuff is what's causing the problem.


(Shawnbel) #5

Yup, I am facing the very same issue using Max and CAT. One of my files works just fine, but the other one is acting up just as your horseman. I can't seem to figure it out, but I'm trying to see if it works from being exported through a different program.


(Shawnbel) #6

@rumenpetrov_6 What I got working just now was saving my fbx and opening it in Motion Builder, then I saved the file in motion builder as an ASCII fbx format and reuploaded it to sketchfab. That may solve your issue.


(Rumen Petrov "Gumbata") #7

Thanks @shawnbel I will try that smile


(Waleguene) #8

Hi everyone,

@rumenpetrov_6: As mentionned in http://forum.sketchfab.com/t/animation-import-issue/3592, the issue is caused by the fact that your skeleton(s) have bones with the same names (see for example Clavicle_R or Foot_R).

If you import your FBX in MotionBuilder, reexport and reimport it, you will see that the duplicates have been renamed (Clavicle_L 1), that's why passing by MotionBuilder is a good workaround for this.

As said in the mentionned topic, a fix in on its way and will be included in the next release smile