Animation is "glitching" to the Origin at random times

animation

(Deuschanz) #1

Hi there, since Sketchfab’s exporter plugin for Blender 2.8 isn’t ready yet, i’ve tried to export it using the old fashion way, namely through FBX.

I’m inexperience in FBX exports, however here’s the breakdown of this animation;
-Has a follow-path, and is animated
-Armature is being moved by the path

https://sketchfab.com/3d-models/shion-animation3-3c0cd129429449af90db2061af84bedb?share=9c71857a18fd947b62e032667951f37dd588099fe4ba558059772a01a2ca76b6

As seen at 00:16 seconds, there are random glitches that occur every once in awhile.

I’m trying to figure out if this is a problem with FBX exports or something to do with how Sketchfab reads FBX animations.

These are my FBX export settings :


(Rémy Bouquet) #2

Just a note. Not really related to your issue but still.
When exporting to fbx for sketchfab from blender, in the armature tab check “Only Deform Bones” and uncheck “Add leaf bones”


(Waleguene) #3

Hi @deuschanz,

I’m able to reproduce the issue when opening the FBX in 3dsMax (and FBX Review crashes) so it seems to be an issue with Blender FBX export which is pretty bad at the moment.
You can see the glitch in the actual animation data:

There are also some issues with normals that are inverted on the model (see this weird dark grey shading), it something that happens frequently with exports from Blender when the model has some modifiers (negative scales can probably cause these issues too).

I don’t really know the state but I would recommand you to give a try to the glTF/glb export that has been added in latest 2.8 builds. With some hope it will give a better result.
Also, something to try is to reimport the FBX after export to see if Blender is able to load it back and give the same result, which can save you some time.

I hope glTF plugin is mature enough to help you to fix this :slight_smile:


(Rémy Bouquet) #4

You could try to open the blend file in blender 2.79 and export it to sketchfab from there. blend files from 2.8 are supposed to be fully retro compatible


(Deuschanz) #5

Works like a charm, thanks


(Deuschanz) #6

Also, opening a 2.8 file in 2.79 … is chaos. Namely because I have nested collections, so probably if I got rid of all of them it might work