Annotation movement not smooth


(Digitaloven) #1

With all the cool new stuff in Sketchfab, I'm trying to get up to speed on "best practices" for setting up models.

I imported a file and noticed that the movement is not smooth between annotations:

Archtest6 by digitaloven on Sketchfab

Movement in first person or orbit seems a bit smoother ... but guessing this is some user error :smile:

I don't think it's a polycount problem ... and I only have one texture but it is 4k x 4k ... model was created in C4D and output to .dae .

Was hoping for smooth movement like this model:

Site de Commarque (with guided tour) by Gerpho on Sketchfab

-m


#2

Hello!

The performance bottleneck on your model is actually the number of separate meshes/geometries. There are almost 8000 separate meshes!

This is a common problem I see with Collada (.DAE) files, usually coming from SketchUp due to the way it handles nested components.

Ideally, there would be just one mesh per material. I'm not super familiar with C4D - is there a way to merge/join all the meshes for the roof material into one mesh? Same for the other materials.


(Digitaloven) #3

Hi James, thanks for the great feedback!

Yes, C4D has a couple of techniques for "connecting" meshes ... I'll take a look at it tomorrow and see which work best.

I'll post results when I get them so it may help others as well.

-mark


(Digitaloven) #4

Wow, that was surprisingly easy and the result is amazingly better ... almost too fast on my blownout mac!

Arch Test8DAE by digitaloven on Sketchfab

James, thanks for the pointer to the Help section ... as a suggestion, you might want it to be easier to find from the home page ... Basically if you go to sketchfab.com, the "Help/FAQ" selection doesn't show up under Community until I selected a "Blog" entry and I had never looked back at Community to find it. Does that make sense?

For the C4D crowd, here's my feedback:
It worked well for this model because I do not have texture maps applied except to groundplane. Basically, in C4D you can pick a material, go to "Assign" and select all the objects using that material, Alt+G group them and then "Connect+Delete" to create a single mesh. Did that for each material and ended up with 4 meshes. I did have some objects with multiple "selection tagged" materials in a single object ... used the SplitToObjects plugin to splitout individual meshes.

Looking into how to do similar with a more complex texture mapped set of meshes ... atlas'ing the textures is the biggest issue, there used to be a plugin for this but the developer no longer supports it for current versions.

-m


#5

Wow, yep. So much better!

Help Center link is in the user drop-down at the moment:

I've had some success in the past using C4D's Bake Object + Connect & Delete features. It will take all the textured objects, unwrap them, join them, and bake a new texture. You can then delete the original objects. There are lots of options during this process like texture size, super sampling, etc. This is how I did the Cooper Hewitt model:

Cooper Hewitt: Main Floor by Cooper Hewitt on Sketchfab


#6

@digitaloven - Just a quick follow up about your weird annotation/camera movement. This article should help:


(Digitaloven) #7

Thanks for the annotation tip as well! I reset all the rotation centers ... I think I had been using first person to set camera angles so had to figure it out in orbit mode ... would be great to see a visual "pivot null" reference (similar to light positions) but I'm guessing that's down the road.

I haven't done a lot of baking with C4D and will be curious to see how the atlas'ing can be optimized ... more tests to come I hope.

You are indeed the support KING! thanks for your help on this.