Another alpha issue!

Hello community!!

I’m having some issues with a rather complicated scene of mine: LINK
When in the 3D settings, I can set up all the alpha textures and they display properly. Once I save and exit, they completely disappear when I go to view my model. If I open up the 3D settings again, I can see the alpha texture files have seemingly glitched out and are no longer displaying anything at all. It seems like alphas are being ‘auto assigned’ to things randomly too, with the trees taking on an entirely different set of textures automatically.

I’ve tried switching the format from alpha to luminance and back, I’ve tried using basically all the blend modes, all to no avail!!

How it’s supposed to look:


How it looks:

Can anyone offer any insight? Thank you!

Hi @bronwenalexina,

We have got similar reports about images processing issues and we are currently investigating the issue.
It seems to affect other non-RGB channels, so it’s not specific to alpha textures (meaning that you might have the issue with other greyscale channels like Metalness or Roughness).

We 'll come back to you when we have a fix or at least a workaround, sorry for the inconvenience

1 Like

Okay, it’s a relief to know it’s not something I’m doing wrong necessarily! Thank, @waleguene, to you and the rest of the Sketchfab team for all your hard work and support!!!

Hi @bronwenalexina,

Just to let you know that the issue has been found and fixed, so it should work now :+1:

1 Like