ArchiCAD into Sketchfab not displaying textures

materials
textures

(Acd Austin) #1

Hi all,

I'm getting a bit stuck here! I've uploaded so many versions of a model so far without any progression.

So i'm using archicad (on both PC & mac).
I'm using both version 20 & 21.

Previously (4 months ago) I uploaded .obj + .mtl + textures in a zipped file & it created lovely 3D models. Now though i'm getting a mix of either models with only a single material surface (white) or i'm able to get Sketchfab to recognise individual materials, but the textures are no longer automatically assigned.

I'm really struggling to find an easy solution to upload architectural models...

Any help or suggestions would be appreciated.

Austin


(Waleguene) #2

Hi @ACD_Austin,

There can be several updates or conditions that could give such results. Could you share a link or a sample reproducing the issue so that we can investigate ?

Thanks!


(Acd Austin) #3

Hi, thanks for a quick reply, nice to see such an active forum/community :slight_smile:

I'm having an issue as a new member, that i can only post 1 photo and no links...! Any suggestions?
I'll try posting a large image with the details on it...

Austin


(Acd Austin) #4


(Bim Life) #5

Hi Austin,

i also use Archicad and to import my model i started to use the .fbx format (named Twinmotion in Archicad) with this settings

i hope to help you

Stefano


(Acd Austin) #6

Thanks for this tip, i've just tried that this morning and with those settings sketchfab still only sees one material... I'm playing with the settings more but still not having much luck!
If i set the textures to export then i get the base colour and each material within the model but still not 'native' textures.


#7

Hi Austin,

You should be able to post links here now.

I checked your account, but there seem to be textures on your models.


(Waleguene) #8

Hi @ACD_Austin,

Thanks for the screenshot.
The main issue here is that textures don't seem to be linked in the exported files, or uploaded with the file.
The issue with OBJ/MTL means that materials can be listed but not automatically bound because their description is not found.

I checked your obj upload, and I see two potential issues:
1- the link with mtl could not be correctly handled by the processing (spaces in material lib declaration mtllib VETSHOW - 21.mtl). It's easy to fix, just rename the .mtl file with no spaces and update the reference in .obj file

2- Textures are not expected to be in a zip included in the main model zip. We stop to unzip archive when a 3D file is found, so here the textures are skipped. I would recommend to put them in a folder instead.

For the FBX version, I see a lot of missing files. Did you try to zip them with the FBX and upload the .zip file ?


(Acd Austin) #9

I thought i'd had progress with the model, it appears it the actual model, i've moved across to the .FBX method as this seems to be the most reliable so far.

Thanks Waleguene, I'll try a new export without any spaces! (well i'll add it to my growing list of 'tips to try')

re the FBX, i'm just uploading the saved file.
I've had success with another model, with the vetshow file, i had success last night by starting a new file without some objects, having attempting to reinstall these today has caused the loss of textures again, i'll be attempting to diagnose the problematic model tomorrow!

Thanks for everyones help so far!