Artifacts on a model (texture compression problem)

textures
3d
upload

(Antonyony) #1

Hello,
I've uploaded a model.


It looked just fine at first.

But a few minutes later the model had some artefacts on its surface.
I suppose it's some kind of compression problems with the normal map.

The model has 2k textures. So i decided to try it with 4k textures. Unfortunately the 4k version has the same compression issue:

Do you have any tips how to solve it? I planned to show the new technology to a customer next week. I mean sketchfab's online 3D opportunities. But now idn how to deal with it...


Normal Maps Corrupt Between Editor Scene and Public Scene
#2

Hello,

I'm sorry about that. This is a known issue with normal map compression. We're actively working to improve this.

James


(Stephomi) #4

This is indeed the compression that doesn't play well with normalmap.
We are working on a better normalmap compression alternative but we don't know yet it'll be released.

The current workaround is to add ?image_compression=0 at the end of the url.

edit: arf james beat me : )


#5

:slight_smile:


(Antonyony) #6

James, Stephomi thank you for the fast feedback! :slight_smile:
I will try "?image_compression=0" on my website. I think it could be nice solution for now


(Antonyony) #7

By the way - what format is better for textures atm? Should i use uncompressed PNG or directly JPG ?


(Stephomi) #8

Since we are going to compress them anyway, it's best if you upload png.

You can upload jpg if you are sure that you won't loose any visual quality though.

Note that in the editor, we always use uncompressed textures.


(Antonyony) #9

Hello,

Some months have passed and I'd like to ask - are there any updates due the problem?
I have the same issue with the model unfortunately :frowning:


(Mrchlblng) #11

@antonyony our current hope is that astc will be a viable option. However the processing requirements are quite high so we're only processing astc normal maps for a sample fo our users for now.
Fortunately, you are in the sample which means that if you change your materials a little bit (like moving the diffuse from 100 to 99) and resave your settings, and waiting a couple+ hours, you should have astc processed and hopefully better quality for almost the same filesize.


(Antonyony) #12

@mrchlblng should I change the diffuse from 100 to 99 only, or also other textures?


(Mrchlblng) #13

@antonyony you just need to change something somewhere in your materials otherwise we won't trigger any processing. We currently do not compare per texture so really any change will do the job


(Antonyony) #14

@mrchlblng Thank you for your help! It fixed the problem! :slight_smile:


(Antonyony) #15

Well, It looks like I hurried. After several minutes, and the the model has the same issues...


(Mrchlblng) #16

Please give it some more time. As I said, the process will take multiple hours at the moment:

  • we wait a couple hours so that if you iterate on your settings and 'save settings' we don't waste processing time;
  • time to process a texture in astc is still very long (~1hr with our current settings)
  • we had a pike of astc tasks so it may unfortunately take longer than usual today

(Mrchlblng) #17

Here you go; astc textures have been generated for the model posted in the first message of this thread. Quality seems much better so still a bit long but probably worth the wait!


#18

Hello,

We’ve implemented an option to reprocess normal maps losslessly to avoid compression artifacts. I’ve reprocessed the model(s) here for you, and you can find more information here:


(Antonyony) #19

Thank you James! It’s really awesome news! I think this option can solve most of the NM problems