Sketchfab Forum

Artifacts with HDRI BG?


(Alvarows) #1

Hey

today was looking some models and found constant artifacts (always the same) on my GTX 660 TI when HDRI background was present.
In fear of my GPU, I checked on my laptop if this could be only a sketchfab issue, and found another class of artifact, always changing from model to model, but artifact in the end. It wasnt always present when HDRI BG was turned on, though.

The issue on my GTX660 seems to be constant. When there is an HDRI visible, it will always display the same pattern on the background. On my laptop, some models with HDRI-BG-ON seemed to be fine, but probably there could be issues with shadows like on the Viktor model that I didnt notice.


(Bart) #2

I think you're seeing our new real-time shadows:

http://blog.sketchfab.com/post/115287035624/new-real-time-shadows-and-better-model

They weren't supposed to be enabled on existing models - we'll have a fix for that in a few hours. I'll let you know when it's live.


(Bart) #3

We just deployed the fix. Could you try again?


(Alvarows) #4

yeah, the shadows issue is now fixed, but Im still getting the HDRI artifact on the background, like with the picture on "zOTACHI" on my gtx660. Havent checked on my laptop yet.


(Bart) #5

Okay, I'll ask our 3D team to look in to this.


(Bart) #6

Update: could you provide some more specifications of your setup?

  • Operating system
  • Browser + Version
  • If possible, URLs of other models that give you similar problems.

(Alvarows) #7

Windows 7 service pack 1 (I hope it isnt this...ahah)
Chrome, Versión 41.0.2272.101 m

zOTACHI Re-rendered by dopepope on Sketchfab


Taiidan Scout by Gearbox Software on Sketchfab


Cowboy Penguin by David Bowman on Sketchfab


Echo of Soul - Warrior by Aeria Games on Sketchfab

I can literally take any file that has a HDRI BG and those artifacts will appear (like the zotachi image). Any other file seems to be fine.

My chrome just updated, will see if changes anything.


(Stephomi) #8

"https://sketchfab.com/models/9f09f0bdb227406fb67b6688852d01d5?earlyZ=0"

Is it working with this link?


Scene editor unstable
(Alvarows) #9

ok, it didnt change anything.

now, on my laptop, I am seeing some pink lines over models.


And this other one, viktor, everytime I rotate the view, I can see some weird sparks over the model. Just look at his armpit.

I couldnt find anything else, and I tried a lot to get more models with problems.

Hope this helps


(Alvarows) #10

I am not on my desktop computer, but it had the "zotachi BG" problem. I cant look at it on my desktop atm.

But on my laptop, this link has some really weird shadows. They are really jagged. Also the hair tends to disappear from some angles, and at a certain distance the head goes completely bald.


(Stephomi) #11

When you copied the link you didn't forget to paste the "?earlyZ=0" at the end ?


(Alvarows) #12

nope I didnt.


(Stephomi) #13

Ok we managed to reproduced the bug.
We'll try to fix it asap.
Thanks :).


(Stephomi) #14

@alvarows We just released a fix for the background glitch, is it fixed for you too?


(Alvarows) #15

yes! it is fixed now! thanks!

btw, your opengl sculpt app looks really good smiley


(Stephomi) #16

Thanks smile



(Shaderbytes) #17

I'm still seeing shadows on my existing models..?


(Bart) #18

hmm, can you give me some links of affected models?


(Shaderbytes) #19

I saw it on this model .. so I went into 3d settings when I noticed and shadows were switched on when they should not have been since its an existing model. I did click the button to test turning it off and on ( just wanted to make sure ) then left it on so I could report it. Im not sure if interacting with the button now eliminates the possibility to debug from your side.. let me go check my other existing models and get back to you.

All I Want For Christmas by shaderbytes on Sketchfab


#20

I expect that toggling the option reset everything to expected behavior.