Asset looks different in Sketchfab 3D viewer than it does Substance Painter, very visible seams

(Mightymorphin) #1

Hey, I'm pretty new to 3D modelling, having only started late January this year. I've just finished my second prop, a DSLR camera lens. The issue that I'm having is that when I export to Sketchfab it looks.. weird. There's a large seam down the middle and the prop looks disproportionate in places.


Here it is in Substance Painter.
Here's what it looks like in the 3D viewer when exported straight from Substance.
Here's what it looks like in the 3D viewer when exported manually to a folder and uploaded.

The second one is a bit better but it only looks okayish with that lighting setup, if I move it anywhere else the seam becomes massively visible again.

I'm not really sure what I'm doing wrong on my end, so any help would be appreciated. I'm also not entirely sure what the proper workflow is for manually uploading. I know how to export the textures to a folder but how and where am I exporting the actual model?

(Stephomi) #2

You should disable flipY in your normal map channel to be consistent with substance.

Also ideally you want to get rid of the vertex seam, it seems your normal map is trying to correct this seam but if we don't have the exact same normals, tangents and normalmap computation of substance it might lead to different results.

(Mightymorphin) #3

Holy shit, that fixed everything. Can you explain what that button does?

As for the seam, yeah. I have a seam running down the front that I really shouldn't, but I'm not really knowledgeable enough to know how to go back and amend the low poly and apply the textures. I've tried that once with a previous asset and the materials spazzed out completely.

Thanks for the help anyway :slight_smile:

(Shaderbytes) #4

I'm curious why is this enabled as the default? All my maps I create dont need this enabled either, I always have to uncheck it.


(Stephomi) #5

There's 2 main ways to encode tangent normalmap. (see last part)

We currently default to "directx" style.
Substance painter is using directX by default but you can change in Edit->Projection Configuration.

(Shaderbytes) #6

wow , I cant believe this y channel thing is so fragmented across packages :slight_smile:

from that page :

3ds Max, CryENGINE, Source, Unreal are negative
Blender, Maya, Modo, Toolbag, Unity are positive