Autostart has stopped working


(Cheshire Creative) #1

What’s happened to the autostart function? It isn’t working.

This has worked well for months but has stopped working. Here’s an example of one of my links which no longer functions. I have tested several and they have all stopped.

https://sketchfab.com/models/f8893204bdbc49b4b624f4d74ff9f75a/embed?autostart=1&preload=1&pixelBudget=0&annotation_cycle=3&annotations_visible=0


Website Change Log
(Cheshire Creative) #2

I've tried;

rebooting PC
using Chrome and Edge
Using link on mobile using wifi and 4G

None of the above makes a difference.

Worked fine a couple of hours ago!


(Moroplogo) #3

I have no problem to view your model with these parameters .

Is it the same problem with autospin=1 ?


(Cheshire Creative) #4

Autospin=1 works

Autostart=1 doesn't
This morning I could use any of my links (which include autostart=1)
This would automatically move the camera through the annotations without any input from the viewer.
Suddenly, the only way the 'tour' will start is by;

click 'select annotation' at the bottom of the screen
click annotation 1
the tour then starts
However, annotations are visible when they should be, and always have been invisible

When you click the link what do you see? Do you fly down to and then around one of the houses without having to do anything?


(Moroplogo) #5

Autostart works but Annotation doesn't start.
Try with these parameters :
https://sketchfab.com/models/f8893204bdbc49b4b624f4d74ff9f75a/embed?annotation=12&autostart=1&preload=1&pixelBudget=1&annotation_cycle=3&annotations_visible=0
Curiously we must indicate the number of the annotation preceding the one that starts the cycle (here 12 instead of 1).


#6

Hmm weird, thanks for the report!


(Cheshire Creative) #7

Well that gives the desired result but something must have changed as I've done over 100 models using the same pasted parameters without a hitch ie: /embed?autostart=1&preload=1&pixelBudget=0&annotation_cycle=3&annotations_visible=0

Any idea if it will be getting fixed? Will be pissed off if I have to go through all my old links counting the annotations and re-writing the parameters. Going to be very embarrassing too if I need to explain this to my customers.

What's going on Sketchfab? Please help, this is insane.


#8

The autostart parameter is working as expected. Looks like annotation_cycle parameter is indeed only working when the annotation parameter is also included.

We'll get that fixed ASAP!


(Cheshire Creative) #10

Thanks James, really hope it's an easy fix...


(Tom Goskar) #11

Autostart isn't working for me either. Clicking "Start autopilot" also doesn't work...


(Cheshire Creative) #12

Hi James

This feature is still broken.
Any idea when it will be working again. It's preventing me getting work out and I'm running out of excuses...


#13

Hi

We're working on a fix, but I don't have any ETA yet. I suspect it will be sometime next week. Sorry for the inconvenience. Can you use the workaround mentioned above just temporarily for new work that needs to go out?


(Cheshire Creative) #14

That'd be a bit awkward as I'd need to change all the links and send them our again to all the people who had them.
Was hoping it could be fixed before anyone noticed before anyone noticed.

It had been working perfectly. What changed?


#15

Nothing changed intentionally, we just introduced a small bug in the code. We have a fix on the way! Really sorry that it happened.


(Cheshire Creative) #16

Brilliant, good to know.

Cheers


#17

Sorry for the delay. This should be fixed now. I just tested your link:

https://sketchfab.com/models/f8893204bdbc49b4b624f4d74ff9f75a/embed?autostart=1&preload=1&pixelBudget=1&annotation_cycle=3&annotations_visible=0