Black Areas On Model


(Tyler Hartshorne) #1

Hi,
So I exported textures from Substance and imported them into Sketchfab and these random black sections appeared. The black is not baked onto the textures and I even manually uploaded the textures and they’re still there. I’m not sure what the issue is. Could I please have some assistance, thank you


(Nomadking) #2

Do you have Vertex Colors turned on? That’s normally the cause with this sort of behaviour.


(Tyler Hartshorne) #3


I thought that was the issue too, but there is no option


(Nomadking) #4

Hmm, if the option is disabled that typically means that there aren’t any vertex colors being uploaded.

@bartv Any ideas?


(Shaderbytes) #5

show the model url and the texture :wink: unless you cant of coarse


(Waleguene) #6

Hi @TylerHartshorne,

It seems to be caused by the diffuse texture and how it has been generated.
If you check with the model inspector (burger layers icon bottom right) and go to diffuse texture, you can see the dark spots in it.
You can also switch to “3D+2D”, click on the object and move the mouse on it: a red dot should be visible and point to the part of the texture used.
It’s the kind of issue you can have if you bake texture with same uv being used in different parts of the model

The vertex color option would have been a good candidate though :slight_smile:


#7

Yes, it definitely seems to be an issue with the uploaded textures.