Black geometry issue in the viewer


(Nakedbuddha) #1

Hey, everyone!

I have a problem that I don't know how to fix:

I upload fbx with animation and morphs and there is a black geometry flying all over the place. However, when I toggle off/on dispacement or transparency slot on a specific material (no texture applied, just toggling the slot) it dissapears and everything is fine. But after saving and exiting edit mode the issue is back in the viewer.

Help? :slight_smile:


#2

Hey,

When the model loads, there's a warning in the console:

a Bone was found after a non-Bone child within a Skeleton. Children of a Bone must be ordered with all child Bones first for correct update order.

Sounds like you have a bone outside the hierarchy?


(Nakedbuddha) #3

Hey, James!

I've got a bone attached to a dummy which is attached to another bone? Can this mess things up?


(Stephomi) #4

The black geometry thingy in the viewer is an issue on our end, it will be solved soon.


(Nakedbuddha) #5

Hey, Stephomi

Thank goodness! I was going crazy trying to figure out what was causing it.
If it will be of any help to you, turning morph animation off helps.

Waiting for a fix then!

Thank you!


(Gilles38) #6

Great ! I am having the same issue just today.
And an additonal one. On my Mac OS X (10.10.5) Mac Book Pro, I have this millions of dark dots on my mesh. All my models that I tested are showing this problem.
It does that on Firefox, Safari, Chrome but it is OK on 2 different iMacs (both 10.10.5) and on Chrome Android (Samsung S7)
I never changed anything on this model. This only thing that happended yesterday is that my MacBook Pro battery got uncharged so I had to set up again some basics parameters (time, date etc...)
Is this due to my computer ? Or is it also a Sketchfab MacBook-specific issue ?


#7

Yep, we're working on it. @stephomi it's something with Intel macs?


(Gilles38) #8

Thanks James for this fast answer.
If it can help, you or @stephomi, I have also a very recent iMac 5K (10.12) which I think is running with Intel Core i5 quadricore (Intel Iris Pro for my problematic MacBookPro). My iMac 5K was working fine this morning until I turned it off around 12:30. If that helps, I can tell if it is still ok when I will have access to it later.


(Stephomi) #9

It should be fixed on next release. It only impact certain apple mac device on certains models with shadows.


(Nakedbuddha) #10

Okay then..I think that's not my case:
- I'm not a Mac user
- It's not a bug on a model for me. It looks like a part of the model flying around. I think it has something to do with animation and morphing being active together. When the both skin and moph modifiers are active on a model I have this problem, when either of them is off everything is okay.

Maybe I can send you *.fbx and you'll look into it?

Thank you!


(Stephomi) #11

@nakedbuddha I was answering to @gilles38 which is a different issue.

Both issues will be fixed on the next release anyway.


(Stephomi) #12

Both issues should be fixed by now.


(Nakedbuddha) #13

@Stephomi thank you very much! It's working just fine now!!

And one more small question kinda on another topic in here to not create a new thread:

I have a plane with additive transparency with 0 spec and gloss, but it still reflects the surroundings. How do I get rid of the reflection completely? Sorry for the off topic.

Thank you, again!


#14

Link to the model?


(Nakedbuddha) #15

here you go:

does it need to be published?

here is a printscreen, just in case.


(Stephomi) #16

Your transparency texture doesn't have any opacity info in its "Alpha" channel so you should probably set the format option to "Luminance" in the transparency channel (sketchfab editor).

As for the reflection, it's the fresnel effect at grazing angle, which you can't control directly in PBR.
However, you can remove the fresnel coming from the environment with the AO channel (by putting a simple 1x1 black texture with occlude specular ON).

For ponctual lights, you are out of luck though, but in your case it was mostly a transparency issue I believe.


(Nakedbuddha) #17

@stephomi Thank you for the enlightement !

Switching to "luminance" helped. Didn't know that nuance.

Thank you, again!


(Gilles38) #18

Yes it is fine now on Macinstosh
Thanks a lot