Sketchfab Forum

Black Model Mesh

upload

(Brianvagie) #1

Hello, I made a gun and one part of my mesh keeps turning black when I upload it into Sketchfab, no overlapping UV's, and looks fine in Substance. Any ideas?


(Stephomi) #2

Check the vertex color option in the sketchfab editor (scene tab).

Also, ideally, don't delete your model when reporting a bug, that way we can still debug it.


(Brianvagie) #3

Oh okay, I'll Rrepost it so you guys can see, thanks!


(Brianvagie) #4

The metal piece thats solid black is supposed to the white, but it's appearing black. Also vertex color is making that piece solid black. Not sure what it is


(Stephomi) #5

Vertex colors are just colors... on the vertex.
However it in the context of substance they probably represent something else (such as materialID or something) so you usually want to disable them when exporting from substance.


(Brianvagie) #6

Oh okay, I'll see what I can do, thanks.


(Brianvagie) #7

How do I disable Vertex Colors in Substance?

-Brian


(Stephomi) #8

I don't know if there is a way.

For now the simplest way is just to disable the vertex in the sketchfab editor ("3D settings" on your model page).

I think I'll just disable the vertex color when we detect the model is exported from substance painter.
I don't think substance painter ever exported vertex color that represented painting, so it's probably fine.


(Brianvagie) #9

Oh okay, It fixed it, thanks for the help bud. :slight_smile: