Blender 2.80 support issues - please post here!

“Bonjour” Jean-Philippe, and thanks for reporting the bugs :slight_smile:

I managed to reproduce the bug on my side considering the distortion problem you encountered. Removing hierarchies is definitely not a viable option in the long-run, so we’ll try to come with a solution to this.

Concerning the BSDF shader issue, could I ask you - if you manage to get your hands onto one - to upload a version of a problematic .blend file ?
The most stable approach for now would be to use the “Principled BSDF” shader in the node graphs, and use its “Emission” and “Alpha” input sockets to plug in the different maps (don’t forget to activate a Blend Mode in the material options if doing so!), without relying on Emission or Transparent shader nodes:

I’m not sure if this workflow could fit your students’ usage though…

Thanks once again for your help, any feedback is appreciated !

3 Likes

Bonjour Loic,

1- Hierarchies seem useless for Sketchfab. For now, it’s easy to remove them on Blender before uploading: “A” select all, “CTRL + P” / Object (Keep Transform). Just let users know about Blender 2.8.

2- Thanks for the explanations with the “Principled BSDF” we will use it with the next project which should also be posted on Sketchfab at the beginning of November.

3- In the Carolane_BSDF_Transp_Bug_1.blend file I only kept the object that has the BSDF Transparent material. It should not have other content that interferes. It comes from the project: https://skfb.ly/6NwzE where the transparent BSDF has been removed. Initially, this project was realized with the interface in French.

In the file mario_BSDF_Transp_Bug_2.blend I left the interface in French and I only kept the elements with a BSDF Transparent material. These elements come from the project https://skfb.ly/6NuNF where the transparent BSDF has been removed.

Bug_Blender2_8_BSDF_Transparent.zip (325.5 KB)

These two clean files do not load into my Sketchfab account. :slightly_smiling_face:

1 Like

Bonjour Jean Philippe, and thanks for the additional feedback and comprehensive files.

The errors with materials that you encountered was indeed due to a bug on our side not correctly taking into account the Transparent node, so thanks for revealing that one :slight_smile:
The fix should be available online during next week.

However, I’d definitely advice you to try and give a go at using the transparency as shown in my previous post if this is applicable to your use-case.
The “Principled” node is meant to be a generic node in Blender, and I think that using its “Emission” and “Alpha” inputs instead of creating new shader nodes really helps simplifying the whole node-graph of the material, and maybe the learning curve for first-time users (as I guess that some of your students might be).

2 Likes

Hello @cirrus7, and thanks for your feedback (and attached samples) !

Concerning your uploads:

Error 13

The Error 13 indeed happens because the Scene is empty. Except if there is something I don’t understand here, I think that this is the expected behaviour, as there would be no point to display a non-existing model on Sketchfab.

Error 20

That one was indeed a little bit more tricky. We did not take into account the possibility of objects disabled in the viewport in the first version of our support for Blender 2.8, which caused crashes.
A fix is going to be deployed soon to fix this error.

Exporting parts of the scenes only

Concerning hidden objects and “render helpers”, it is true that the behaviour is not always the most intuitive…
We usually “un-hide” those and export them to Sketchfab as such objects are often used as particles, boolean parts, curves… and often needed for the final models to look good.

Although we’ll try to make this more intuitive when processing the files on Sketchfab, one suitable option you could use would be to use the Sketchfab add-on if you have not tried it yet !

It has an export feature with a “Selection Only” option, which should allow you to export… only the selected objects :slight_smile:

You can download it on github (I’d suggest installing the latest version, the 1.2.1): https://github.com/sketchfab/blender-plugin/releases

Thanks again for your feedback, let me know if something was not clear or if I can help further !

3 Likes

Hi.

I tried to upload a Grease Pencil (Blender 2.8) file for Inktober 2019 challenge. It had only Grease Pencil strokes, and upload finished with an Error 13. Maybe grease pencil strokes are not supported. If that is the case, will this be a future feature?

Thanks.

Hi,

Grease Pencil is not currently supported, and it’s not currently planned to support it. Is it possible to convert Grease Pencil objects to meshes?

Hi, @james, thanks for your answer.

I see.

Yes, but I think it is not very useful for just drawing some sketches.

My main concerns are about animations in 2.79 that rotate on the wrong axis when they are saved in 2.8 and upload in sketchfab. Please note that they work in Blender, only with the transition Blender to sketchfab, it seems non functional.

The other bugs I get is when I upload files with alphamasked channel. Sometime, all alphamasked material end in sketchfab a one single material called “material_0”. I never got this in 2.79. I believe this bugs has been already referenced by your wonderful team, I believe

Hmm. Can you share some sample uploads with these issues?

Ok James,

Here’s the model uploaded from Blendr 2.8. Doors are rotation the wrong way, and are not at the right. Something I don’t encounter when I play the animation in Blender 2.8.

Here’s a previous model saved with Blender 2.79, working fine.

Regarding the material_0 issue, here’s the model I’m having issue with it’s not yet published but I guess that, as an administrator, you can access draft. It also have problems with animation as the wings should be moving too, but here only the door does
https://sketchfab.com/3d-models/carreidas-160-717a7195953a45139b297610892b8c94

1 Like

Bonjour,

Regarding the problem of distorting objects in Sketchfab with Blender v2.8 files containing multiple sub-hierarchies, you will probably be interested to know that I saw the same problem when importing .blend 2.8 files into Unity.

Also, I noticed that Sketchfab is much less sensitive to topology problems created by novices with Blender (crossed vertices, non-planar n-gone …) than Unity can be.

2 Likes

Here is animation in Blender (2.82)


But after I upload, it deform like this.

What happend? Help me please!

@norgeotloic any insights here?

Issues that i could spot and how to solve:

Exporting to fbx gives usually better results with that. After a look on your model you also seem to have too many vertex groups affecting the model. I deleted every vertex group except for the “DEF- groups/ Bone.001…005” and it worked fine. Those are the ones we need afterall. However they do need a little manual fixing, so you should check on that part(jawline for instance). Perhaps sketchfab got confused with this many many vertex groups or something? don’t know… :thinking:

  • Kneejoint rotation: I experienced something similiar with one of my models, and I’m not sure why, but perhaps there are issues with how sketchfab handles bone-constraints? I got that fixed by simply baking the animation. Search with f3, select bake action. Framestep should be between 5-10( otherwise way to many keyframes). Enabling all checkmarks will ensure animation will play and get exported correctly. Or maybe increase distance of the poletarget bone.

EDIT: Why do you have 3 Armature modifiers on your mesh?

1 Like

Wow, I thank you guys very much for really detail advice. I’m just a newbie in 3D, so this is very helpful for me.
I really appreciate your devotion. I’ll try your advice and find the way to improve my model.
Thank you very much.

Hi, I’m way new at uploading to sketchfab, (and trying to enter it into the circus challenge) and having some real trouble exporting, uploading a blend file (with or without the blender plug in) gives me the error 20, which from what I can tell, “they” already know about, and are trying to fix…

if I export to FBX its at a horrible angle etc

So I exported to glb, where it kept the correct orientation, it messed up the images, and didn’t allow me much control in the sketchfab interface… (made shadeless to keep a semblance of the UV layout)

help by tangent.boi on Sketchfab

I would be delighted for any advice
But think the biggest specifically blender 2.8 question is, I’ve been fight with, and losing to the “bake” functions and NLA editor, totally failing to get ALL the animations (armature movement, eyestalk blinking, box opening and descending, movment of “the food”, shapekeys of the bite of the food) all as one animation instead of a bunch of little ones…

Many, many thanx in advance…

Hello @tangent.boi , and sorry for the late reply.

I’ve been able to test your model, and the error 20 when uploading a .blend file is a little bug in our processing pipeline, which you can easily workaround:

The mesh called “collapse.manfoot.002” in your .blend scene had some unresolved keyframes (called “OR.Skullinflate”, “NW.Skullinflate”…) managed by a driver, which resulted in a bug on our end of the processing.

image

Simply deleting the drivers (right click on the value field -> delete driver) linked to those shapekeys before uploading the .blend file seemed to solve the issue and allowed me to process your model, resulting in what I think is the animation you are going to on Sketchfab:

Hope this will allow you to get the model uploaded :slight_smile:

Loïc

PS: sorry I just noticed that you had uploaded models probably taking this into account after a comeback from our Support team.

I don’t see major differences between the animation and your latest model.
If something still seems to be wrong, could you detail what’s not working as expected ?

1 Like

The track to constraint and locked track constraint do not work if saved in 2.83, but the same file from 2.69 works

Track To Problem.zip (168.1 KB)

hello there, ive just downloaded the sketchfab plugin and installed it and applied it to blender 2.9 however the activation tab is greyed out with no buttons. Is there a fix for this?

Which version of the plugin are you using? Please make sure you’re using at least 1.4.0.