Blender 2.80 support issues - please post here!

We announced our support for Blender 2.80 files yesterday, and our developement is still ongoing. If you find any issues, please report them on this topic and include a .blend file that has this problem if you can (or mail it to community@sketchfab.com). Thanks!

5 Likes

Thanks for the 2.8 support. I found two bugs:

  1. Upload Error (20) when an object is disabled in the viewport
  2. Upload Error (13) when having multiple scenes especially if there is an empty scene. Sometimes I had this error also with a scene having linked objects from the other scene

Minimalistic files attached

Sketchfab-Error-13-20.zip (216.7 KB)

1 Like

As a feature request: I found those bugs by searching for a convenient way to upload not the whole model but only parts (some objects) of it. It seems that hiding in viewport and hiding for rendering doesn’t do the trick. Sometimes I have “render helper” objects like shadow catchers etc. in my scene which I don’t want to have uploaded to sketchfab. I think it would be useful to have a way not to upload them to sketchfab. I would say using the convention that objects which are “Disabled in Viewports” or “Disabled in Renders” are not processed by sketchfab. Or is there already a way to do this?

1 Like

Bonjour,

I have objects modeled with Blender 2.8 that are distorted after uploading to Sketchfab. The geometries are simple primitives from the library. They have no topology problem.

I think the problem is related to the number of sub-hierarchies.

I had this problem by downloading the .blend file and the .fbx export.

I found 2 workaround:

Use an .obj export

Or

Decrease the number of sub-hierarchy level (to download a .blend file).

:slightly_smiling_face:



In the picture the steering wheel and the wheels are distorted.