Blender archimesh windows and doors not displaying


(John Belding) #1

I have a house model using archimesh rooms,windows, etc. When I render in blender the window is transparent as it should be. In sketchfab the window displays as a box and no matter what texture/opacity, etc I try I can’t see through the window. It appears that sketchfab is displaying the hole cutter for the windows. If I hide the window group, hole, window before I import to sketchfab I can see the hole, but can’t put a glass material over the hole. It involves a lot of extra work to hide the window and the result isn’t very good.

Suggestions?


(John Belding) #2

I found that if I hide the cutter object, I can use a glass texture on the windows and it looks good. Still a pain to have to hide the objects.


#4

Can you share a link to a model with this problem?


(John Belding) #5

The one with just a straight array is

https://sketchfab.com/models/73a449390bae42b29917103cd11c186a

The one that works with less trees and a single loop around the property is

https://sketchfab.com/models/5fb1c57d20d3446392491c0eda2c7026

The one that has two curves around the property (I just uploaded it again since I deleted it a few days ago) is

https://sketchfab.com/models/6acd742d8d64483090b408991b584b72

Thanks for your help.

John B.


#6

Thanks! It’s probably because we don’t support the Cycles renderer directly, so the material settings don’t all come through because there is no 1:1 translation to our renderer.

You can just turn on Opacity for the Glass material in 3D Settings though.