Sketchfab Forum

Blender to Sketchfab - Material issues with mirrored objects [Partially Solved]

blender
upload
3d

(Keithg) #1

Found a really weird issue while uploading a Blender model to Sketchfab. I've found a work a round and I thought I'd share just in case it helps others. Also to see if anyone can cast any light as to what's going on.

I created a model in Blender and mirrored 3 of the objects (in Object Mode). Everything is fine in Blender but when uploaded to Sketchfab, 2 objects look semi transparent. These objects have the same material as other objects in the model which look fine. Something is going on with the normals on 2 of the 3 flipped objects.

I tried everything including recalculating and flipping the normals on these two objects but nothing works and you cannot get the material to look right in Sketchfab.

My work a round
Do not mirror objects in Object Mode. Go into Edit Mode of the object you want to mirror, select all vertices and apply a mirror modifier. Go back into Object Mode and apply the modifier. Duplicate this object, then go into edit mode for each of these objects and delete one half of the meshes (opposite sides). This gives you the two mirrored objects you wanted and works perfectly in Sketchfab.

My question
Does anyone know what causes this and why 1 of my objects mirrored perfectly but the other 2 went wrong. The only thing I can add is the object that mirrored OK had a lot more vertices than the 2 that didn't.


(Bart) #2

You can also try to 'apply' the transformations when working in object mode: CTRL+A. Let me know if that helps!


(Keithg) #3

Bart,

Makes no difference. I followed the same steps as before. Duplicated an object using Shit-D. Went to Object, Mirror, X-Global to mirror. I tried applying both Make Duplicates Real and Visual transform and still the file comes in to Sketchfab with a weird semi transparent texture.

As most of what we'll be doing will end up on Sketchfab, I'll stick to mirroring meshes in Edit Mode which isn't too much trouble.


(Simon Kratz) #4

Hi keithg!
Interesting issue, I'd love to take a look if you could provide the original .blend file. :slight_smile:


(Keithg) #6

Here's a better example https://skfb.ly/VUW9

The logo on the left is a duplicate of the one on the right that has been mirrored.

They share the same material


(Shaderbytes) #7

I downloaded your file, The mirrored object has a negative xscale. You need to fix this by doing two things. First in object mode do CTRL A and apply the scale. This will reset the scale but it will also invert all the normals! ( this is what is actually happening when you upload the model)

The second step after applying the scale is to go into edit mode , select all geometry , then Press the "W" key and select "flip normals"

Your problem why you dont even see these obvious issues before uploading is that you have the viewport shading set to material. You should check it with solid , which would show a darker shade of your material color because of the incorrect normals , or also just press the "N" key to bring up the properties panel and on the "shading" component select "Backface Culling" . This would also quickly show you when faces are incorrect.


(Kage G) #8

This is me on my home account. Thank you shaderbytes. I'm normally very diligent about applying scale but never even thought that mirroring would affect the scale. Your solution works perfectly and at least I now understand what went wrong. I've only been learning Blender for the last few weeks and am still learning the ropes.


(Bart) #9

Thanks for helping out @shaderbytes!


(Simon Kratz) #10

Aw I was too late :smiley:
Nice job @shaderbytes! Glad you guys figured it out :slight_smile:


(Twitte King) #11

thank for your fix suggestion! we have similar problem, the mirror modifier is not functioning after uploading to sketchfab. but i can not really apply modifier, since i have half of an animated character with armature mod(with further bone constraint with some empties) and shapekeys animations. the scale is (1,1,1) the normals are all pointing the right way.
i apologise for reviving this old thread, thank you in advance


(Shaderbytes) #12

what format are you uploading? Did you try export as an fbx? In the inspector when exporting fbx , there is an option on the second tab to apply modifiers. make sure this is selected. It is non destructive and only apllies to the export not your scene object.

Take note that there are some conditions where the type and order of modifiers used results in that not even blender itself can apply the modifiers. If this is the case then there is no hopw that another application can do it.