Brower doesn't load 3D models anymore


This is a random model I’ve clicked, but in fact all models aren’t loading for me on the browser, I tried refreshing and restarting but nothing worked so far. Anyone have an idea what it could be?

Hi Niels,

We’re not aware of any loading issues right now, so this suggests an issue on your end. Could you try loading a model in a private browser window (this disabled most extensions), or disable your browser extensions to make sure nothing interferes? Do you have access to another browser to test?

Hey thanks for helping me out, I tried the private browser but didn’t help so far. Currently have no extensions applied to my browser. It’s weird because it works on my phone just fine.

Hey there, i have the same with models that aren’t loading, it first happened yesterday nothing worked… I tried restarting different browser, tried a private browser. This morning it seemed resolved but now it’s back.

Hi,

as we don’t reproduce, it would help if you could provide more details:
Could you post a screenshot of a https://webglreport.com

Thanks!

Hi all,

If anyone is using MS Edge, can you try the troubleshooting steps here:

I highly suspect this is related to a recent issue of WebAssembly (WASM) support being disabled by security settings of browsers. I haven’t seen it in anything but Edge yet, but since it’s Chromium-based I can easily see it being an issue in Chrome and other browsers.

To confirm, especially if you’re not using Edge, can you open the Developer Tools, go to the Console tab, refresh the page, and see if there is some error message about “DITER-W”?

If you’re not using Edge, it may be some similar privacy/security setting (or ad blocker-like plugin) that’s blocking WASM, and you’ll need to allow it, add sketchfab.com to the exceptions list, or similar.

1 Like