Browser WebGL Issues in Chrome

chrome

(The Alkaris) #1

Why is it that I can’t view uploaded 3D models in Google Chrome when its clearly WebGL compatible? Something tells me Sketchfab site here does not use any of the standards available for WebGL rendering that browsers most commonly support, and according to your FAQ you need to enable Hardware Acceleration in order to view them? Sorry (not sorry) but no, there’s a reason why I don’t enable Hardware Acceleration, is because it causes issues for me on other sites I visit, and it’s not something I will ever enable just for Sketchfab, so unless Sketchfab uses the same WebGL standards as everyone else does, I don’t see this being a good site at all for uploading and viewing 3D models.


(Paul Sketch) #2

Welcome,

Problem being that Chrome can disable “Hardware Acceleration” because of many things outside our control (too many tabs, too many crash, etc), and user would end on “software emulation” which is clearly a degraded experience (much slower, use much more battery on phone/laptops, make cpus fans go full noise, needs high-end cpu, etc)

So we do require “Hardware Acceleration” because allowing “software emulation” would make sketchfab experience overall a pain for the vast majority of our user.

For user without the webgl hardware capabilities we offer the fallback viewer, which is a 360 turntable, making sketchfab models viewable on all possible platform

“there’s a reason why I don’t enable Hardware Acceleration, is because it causes issues for me on other sites I visit”
Why reporting issues on those other websites is not a solution ?