Bug with .ply import

magicavoxel
3d
upload

(Dune Holy) #1

There is a problem with uploading .ply models. They become extremely dark. I faced this bug yesterday and it still don't fixed :pensive: examples:


(Stephomi) #2

In the editor:

  1. Switch the vertex color to linear color space because we now expect vertex color to be in srgb.
    You can also change the gamma export option in magicaVoxel ply option so that it exports directly in srgb color space (bake -> gamma).
    It's best if you change the magicaVoxel option export because you can avoid some color banding issue since ply is exported with 8 bit color.

  2. Set the diffuse color to fully white instead of the default grey
    The vertex color is multiplied with the diffuse color, we'll default to fully white in a soon future.


(Dune Holy) #3

Thanks!