C4D plugin updates

Hi there :wave:

As some of you might have noticed, we have recently been updating our plugin for the latest versions of Cinema4D (R20 and R21).

The latest version of the plugin is available for download HERE (along with installation instructions).

Upon successful installation, the plugin should be available in the Extensions (R21) or Plugins (R20) menu:

And as we have noticed that some users still use a now deprecated version of the plugin, here is a quick recap of what the recent updates brought (Spoiler: you can import AND export models from and to Sketchfab :wink:)

Importing models from Sketchfab

You can browse and choose a model to import directly through the plugin’s interface.

Although most of the models available for download should import seamlessly into Cinema4D, please note that some discrepancies with Sketchfab might still exist, especially concerning PBR materials (as Cinema4D does not support those natively, the conversion results might sometimes feel akward).

Also, we have recently added animation import to the plugin features.
This support should be pretty robust, but we have noticed that a small percentage of animated skinned meshes can get deformed on import. Do not hesitate to let us know if you encounter such cases.

Exporting models to Sketchfab

The plugin also provides you with a way to directly upload a model to Sketchfab. As we rely on Cinema4D native fbx export for this feature, the upload should behave as if you manually exported and uploaded a .fbx file to Sketchfab, just with less hassle !

Note: If some of you were using the old C4D exporter, you’ll need to delete it from its installation directory before using the new plugin first, or you might encounter Python errors about “plugin ids conflicts” and impossibility to login.

Feedback welcome

As usual with such updates, do not hesitate to let us know if you encounter problems using the plugin !

The best way might be to directly reply to this thread - or send me an e-mail directly (if you do not want your files to be made public) at the address loic dot norgeot at sketchfab dot com.

To help us troubleshoot your problem, please link:

  • The url of the problematic model(s) on Sketchfab (the model you tried to import or the one you uploaded).
  • The original .c4d file for upload problems, ideally in a stripped down version containing the parts you identified to be problematic
  • If it is not empty, the logs of the Python console (available under “Script->Console->Python” in C4D R20, or “Extensions->Console->Python” in C4D R21)
  • Any other screenshot or info you think can be relevant :+1: !
2 Likes

I tried in both R20 and R21 (Win10) to log in (seems like login doesn’t take) with my Basic account, but the Upload button never activates. I’m unable to even begin testing this plugin.

If you open Script → Console → Python and try to log in, do you see an error about a missing path?