Cannot change format to alpha under Opacity

Just like the title says, is there any reason as to why I am unable to change the formation from “Luminance” to “Alpha”. The option is there in the drop-down, but the option stays on “Luminance” no matter what format I try to choose.

I have two different objects that use Opacity and there is no problem with the other one.

I need “Alpha” because “Luminance” makes the object see through.