Cannot Pan or Orbit Model Touchscreen


(Adlp Dash) #1

I tried panning and orbiting some models using the touchscreen mode (currently using a touchscreen laptop and Google Chrome) its not responsive. I can click on the icons via touch but the orbiting and panning is unresponsive. Instead I get a light-trail when I try to orbit and a square when I attempt to zoom-in. Any ideas?

I’ve also tested other websites like p3d and it works fine with their viewer.


#2

Hmm. What Operating System and laptop model are you using? Does it work in other browsers?


(Adlp Dash) #3

I tried Edge as well, no luck. I’m working on a Razer Blade


#4

I don’t have that device, but I tried a few different touch screens and navigation worked as expected.

Do you see any errors in the Developer Console of Chrome when the page loads or when you try to use touch input in the viewer?


(Adlp Dash) #5

Ok, so I got it to work. It seems to have been a mistake on my part.
On this PC you have to press your finger down until a square flashes, and then you can start orbiting or panning around the model.
Is this the intended design?

Thanks for the quick replies btw.


#6

Hmm, glad you figured it out. Sounds like a behavior unique to that device. I’m not sure there’s anything we could do on our end.


(Maksw Beebuzziness Com) #7

Hello,

I have exactly the same problem with this context :
Chrome + Desktop + touchScreen

I have seen that chrome is disabling by default the onTouch API’s on desktop and they suggest using the PointerEvent API’s instead : https://www.chromestatus.com/feature/4764225348042752

When I turn on the flag : onTouch API’s to enable, everything works well.
I have tested this on 2 desktops and have the same results.

Can you confirm my theory that for the moment you are using the touch API and this is why is not working out of the box with Chrome ?

Do you have plans to work on this particular issue ?

Thanks

FYI : On Edge the object just rotate slightly so it’s not working either :frowning: but it is working great in Firefox :slight_smile: