Cannot Pan or Orbit Model Touchscreen

I tried panning and orbiting some models using the touchscreen mode (currently using a touchscreen laptop and Google Chrome) its not responsive. I can click on the icons via touch but the orbiting and panning is unresponsive. Instead I get a light-trail when I try to orbit and a square when I attempt to zoom-in. Any ideas?

I’ve also tested other websites like p3d and it works fine with their viewer.

Hmm. What Operating System and laptop model are you using? Does it work in other browsers?

I tried Edge as well, no luck. I’m working on a Razer Blade

I don’t have that device, but I tried a few different touch screens and navigation worked as expected.

Do you see any errors in the Developer Console of Chrome when the page loads or when you try to use touch input in the viewer?

Ok, so I got it to work. It seems to have been a mistake on my part.
On this PC you have to press your finger down until a square flashes, and then you can start orbiting or panning around the model.
Is this the intended design?

Thanks for the quick replies btw.

1 Like

Hmm, glad you figured it out. Sounds like a behavior unique to that device. I’m not sure there’s anything we could do on our end.

Hello,

I have exactly the same problem with this context :
Chrome + Desktop + touchScreen

I have seen that chrome is disabling by default the onTouch API’s on desktop and they suggest using the PointerEvent API’s instead : https://www.chromestatus.com/feature/4764225348042752

When I turn on the flag : onTouch API’s to enable, everything works well.
I have tested this on 2 desktops and have the same results.

Can you confirm my theory that for the moment you are using the touch API and this is why is not working out of the box with Chrome ?

Do you have plans to work on this particular issue ?

Thanks

FYI : On Edge the object just rotate slightly so it’s not working either :frowning: but it is working great in Firefox :slight_smile:

Is there a solution to this coming up anyday soon?

I have a Surface pro 4 and I still have this problem. Nothing happens in Chrome, Slight rotation in Edge and nothing exept a square in Firefox.

Very frustrating as it works perfect on Android devices.

Hey i know this is marked as solved but problem still persists. Still can’t get touch working on laptop :frowning:

Hey. What make and model of laptop? What browsers have you tried?

Hey james thanks for the reply.
Checked on both Chrome and MS Edge
Checked on:
Thinkpad X1E
Surfacebook
Cintiq companion

Works on ipad but havent found a single windows 10 device that works.

1 Like

In Chrome, can you try going to chrome://flags/#touch-events and enabling the “Touch Events API” flag?

1 Like

Hi James yes that did the trick! Thank you!

Interestingly on windows 10 I got a warning saying “experimental features…compromise security etc” I remember touch working fine before, wonder if these got turned off during a security update!

Also I see alot disabled, would enabling any others help improve performance at all?

Thanks!!

1 Like

The default settings for most flags is usually fine unless you’re experiencing a specific problem or really know what you’re doing.

chrome://flags/#ignore-gpu-blacklist is useful if Chrome blocks WebGL on your hardware

chrome://flags/#enable-gpu-rasterization might be useful but I don’t really know :slight_smile:

There are plenty of clickbait-y articles out there that might be worth looking into:

https://www.makeuseof.com/tag/enable-google-chrome-flags/
https://www.maketecheasier.com/chrome-flags-better-browsing-experience/

And other searches like “Chrome flags performance”. I’ve definitely experimented, but never done any scientific tests or benchmarks.