Sketchfab Forum

Can't add materials to model


(Cdeeks) #1

Hi, I have uploaded a model as obj and FBX and when I try to add my materials I don't get the option to select parts of model. the model is in 3 parts but I keep getting weird names.


#2

Hi,

What software are you using? Can you send me a link to the model so I can take a closer look?

Thanks!


(Cdeeks) #3

Hi James, i am using 3ds max and i have tried OBJ and fbx formats.


#4

I don't know about the FBX, but this OBJ version is missing the "Caravan2.mtl" file. Without it, we cannot generate material definitions.

Have you tried the 3ds Max Exporter plugin? https://sketchfab.com/exporters/3dsmax


(Cdeeks) #5

I added the mtl file on last upload still same issue. i will re-upload and see what it does. Ok I added the mtl file and still same issue.


#6

Thanks, the MTL file only has one material defined: "07___Default".

Can you try the Exporter plugin? https://sketchfab.com/exporters/3dsmax


(Cdeeks) #7

I will do thank you!


(Cdeeks) #8

The Import script seemed to have worked. split it into 3 objects thank you.


#9

Awesome! Thanks for letting us know.