Sketchfab Forum

Can't disable backface culling in one model


(Simon Kratz) #1

Hi all users and Sketchfab staff,

I got a problem with one of my models. For some reason its backfaces seem to be always culled despite "double sided" is setin the material settings. It works for all the other models though, so please have look at it:

Wooden Christmas Ornament - Final - UCAC4 by essimoon on Sketchfab

Both the bells and the small ropes are backface culled. I checked all the settings. They should be ok, so maybe that is a bug?
Please check it out if you got the time, thx in advance smile


#2

Hmm weird. @stephomi ?


(Stephomi) #3

Hmm... on what material do you have the problem ?

Culling is not a global setting, it's per material, so you have to do it for every materials if that's what you want.


#4

@stephomi check the ropes/strings, for example


(Simon Kratz) #5

@stephomi Yes, I assume I set up everything correctly. For some reason it still doesn't show the backfaces though.
You could probably look my settings up right inside the model with some dev tool magic but I just took a quick screenshot to show that it really doesn't seem to work here. smile
It's fine for other models, maybe the error is on my side if I made an export mistake but I really don't know though.


(Stephomi) #6

Ok I detected the problem and fixed it. It was definitely a bug smile
It will be live on the next sketchfab release (next week I guess as it's not urgent).

Until then, you can switch the rootNode face rendering setting to double sided.


(Simon Kratz) #7

That's great thx! smiley Did the rootNode object pass the single sided rendering on to its children?^^


(Stephomi) #8

Yep that's it.
The rootNode is a default material that we create in case we detect that some geometries don't have any materials (in this case the wooden part for example).

For some reason (aka bug stuck_out_tongue ), the back face culling attribute of the rootNode overrode its children.

PS: we might have another bug concerning the rootNode.
If you enable a channel (eg emissive) that is disabled for the other material, then it will override these channels.
We'll try to fix that too.

I'm pretty sure you are confused now smiley


(Simon Kratz) #9

Haha thx for the explanation, guess I pretty much got what you said smiley Doing all the shaders for our current main game project, so I know some bits about how realtime rendering works. Glad you were able to find the cause, thx for looking into it.