Can't navigate Sketchfab App properly - Samsung Gear VR | Galaxy Note4


(Chyslns) #1

Hello everyone!

I just got my hands in Samsung Gear VR headset and I downloaded the Sketchfab app in a Samsung Galaxy Note4.

The Sketchfab App works fine when I open it with the phone in my hands, but once I put the phone into the Gear VR it behaves as if the touchpad would be constantly receiving finger taps (think of holding down a key on a keyboard). So, whenever the center point hovers over a "clickable" area it goes in there; this made me navigate a big part of the app´s gallery in less than a minute haha.

I'm using a Galaxy Note4 with the Android Version 5.0.1 and a Samsung Gear VR Model SM-R320

And the Sketchfab App was just downloaded today, so I think I got the latest version of it.

At first I wasn't able to see the Sketchfab App on the phone, because as soon as I mounted it on the headset, it would automatically open the Oculus App, even while having the Sketchfab app open and running. I tried the "Package Disabler Pro" workaround to be able to see other apps different than the Oculus App, and that let me stay in the Sketchfab app with the phone mounted on the headset but now it does this "perpetual clicking" even without touching the headset with my hands.

I noticed that it worked for a few minutes after juggling the front part of the headset (black part) with the phone mounted in there since it was a bit loose, but I don't think that really fixes the problem, since I was able to navigate using the touchpad in other VR apps without trouble.

Any idea of what may be causing this? I'm asking this over at the Oculus forums too just in case is a hardware issue, I don't want to leave that out of the question.

Hope this is not confusing, and thanks!