Cardboard VR camera positioning

cardboard
vr

(Bhal) #1

Hi,

I'm trying to set up a model for viewing in Cardboard, and struggling. The model is of, in essence, a room (it's actually a bridge, so a room with two walls missing. Two problems:

Minor: VR mode seems to ignore the initial view, and chooses it's own start location. I'd like to set up to start underneath the bridge.

Major: If I teleport to a position under the bridge, the camera height is set to above the bridge (like, above the ceiling of a room looking down).

I've tried rescaling the model before uploading but that clearly has no effect. I tried resetting the origin and it didn't seem to change anything.

This page https://blog.sketchfab.com/how-to-set-up-a-cardboard-vr-scene-for-sketchfab/ says "Try to place your camera at ‘eye level’." Well exactly, that's what I want to do, but I can't see any way to preset the camera position or to control the camera height in VR mode.

Hamish


(Aaronopenshaw) #2

Hi there, I am having similar issues but I understand fixes are in the works from support.

In the VR mode, touch the question mark icon and then at the bottom of the screen in the centre touch 'reset view'. This will take you to your initial view. Only issue then is the teleportation is not working as you have detailed. I also find the circular animating teleportation icons destroy the magic of immersion.

Cheers Aaron.


(Aaronopenshaw) #3

A temporary work around I have found, which is not perfect is to set up different annotation view points like I have in this model: click here. The only issue is you have to take your VR viewer off to change view points but it works by keeping you inside your model.

Cheers, A


(Bhal) #4

Aaron,

Thanks for that. I tried using an annotation, and it didn't work. I can see that it can work, but getting it right looks to be a trial and error game.

After your comment I realised I was doing it wrong.

The camera position for an annotation varies between the normal and VR viewers. (The annotation markers seem to appear randomly in the VR view, which doesn't help). As far as I can tell, when you add the annotation, sketchfab records the field of view, and tries to recreate that in VR. But in VR the angle of view is different, so the camera ends up in a different place.

Once I worked that out, I was able to use an annotation to get the at roughly head height and central in the modelled space. Annotation 8 in this model

Hamish


(Stephomi) #5

The default vr scale is dependent relative of the bounding box of the model, it's not absolute.
Absolute scale can't work for us because people don't care a lot about unit.

Soon an option to change the initial position, scale will be introduced.
Annotation in vr will be improved too.


(Bblakesley) #6

The scroll doesn't seem to work on iOS. I can't reach the reset view - amazing....


VR in Safari, Chrome not working
(Aaronopenshaw) #7

I use a Samsung Galaxy S4 for my Google Cardboard VR and the 'reset view' is visible when you touch the '?' icon. The 'reset view' appears over the annotations selector (if you have loaded annotation views into your model) at the bottom centre of the frame.

I just tested it on my iPad Air. When you touch the '?' icon, the 'reset view' does not appear but it is there because when you touch the area where it should be it still resets your view.

Cheers A


(Bblakesley) #8

You just made my week. Thanks! I don't have annotations, but I just blindly clicked in the center bottom as you suggested and it worked pretty well. The frame rate goes to hell, but if you click the animation selector and then click off of it the rate goes back to normal. Something is a bit off with fov, but at least it works. Thank you very much.


(Aaronopenshaw) #9

Hitting the reset view takes you to your initial view which is also your thumbnail view when you look at all of your models.


(Misterrandyclark) #10

These tips are very useful Some vr camera can come very tricky.