Cinema 4D - morphing

Hello, I understand that the wonderful team at Sketchfab has now enabled animation and morph targets. My understanding of this in Cinema 4D is to use the Pose Morph tag. From there, I have tried the exporter plugin as well as exporting an fbx file. I am not getting the morph information to translate from Cinema 4D. I have tried a variety of settings but I am curious if this is even supported from Cinema 4D since “morph targets” are in Beta still? (per this thread: Animation Beta: we now support Morph Targets!)

Thank you!

@waleguene do you know?

Hey @shawn2d2,

morph animation is no longer considered in beta.
We however still have a limitation on the geometry size; currently, if your geometry has more than 65535 vertices, we’ll make it static. Could it be the case for your model? We’ll likely improve this soon!

Thank you @james and @mrchlblng

My model has approx. 2928 points. This includes the number of points of the target object that I am morphing to.

Here’s a link to a screen capture of what I am trying to accomplish:

Thank you,

Hmm, could you share the FBX or the original C4D file?

Feel free to PM me or email if you don’t want the file public.

Hey @shawn2d2,

I took a look at your model and reimported it in several 3D softwares (including Cinema4d) and it seems that morph animation keyframes have not been exported in FBX. If you try to reimport it in Cinema4d you will see that there is no morph animation.

I recreated a simple morph animation from your model and reexported the result, and it works on Sketchfab. I think it is about export parameters since it is moving in your GIF.
To give you some info about what I did, I simply set the morph keyframes by the cursor in the timeline and then used the “Record Sliders” button in the Morph edit menu (in “Animate” section).

Here are the export options I used:

Hope it helps :smile:

1 Like

@waleguene Thanks! It works! I was animating the strength parameter as opposed to the record slider parameter.

Thanks for all your help! @james @mrchlblng Your site is great, thanks for staying on top of your forums!


1 Like

I’m looking for a way to export morph or pla to sketchfab but nothing works…
Hi, I’ve tried to export with your settings but it doesn’t work too!
My version of fbx exporter is 2018.1.1 c4d R20.
Here’s a screenshot of available settings.
Thank’s for help.


1 Like

Hi, I apologize, it works now!

I retried using the record slider instead of the hotkey (crtl+click) when creating animation keys and effectively it works.

1 Like