Color texture error in my model

(Nestor F. Marques) #1

The marble base of this model is supposed to be green, and in fact, when I edit it, is green marble, but in the finished model is blue to me. Do you see it blue? or is it just me...

I tried erasing the texture and uploading it again. It worked for a while, but now (30 minutes later) is failing again.

This is how I see it when I edit it

An here is the error I've been getting

Here is the link to the model

Hércules Gaditano by Néstor F. Marqués on Sketchfab

Thanks for your help


Were you following a workflow like this?

Copying your textures into all those slots can have really unexpected results in combination with our texture compression. I'm not sure exactly what's causing this specific issue. Maybe @stephomi can help?

(Nestor F. Marques) #3

I just checked and it seems to work again. Fingers Crossed

If it fails again, I'll detele the textures from the slots. Maybe that's what is happening.

And yes! I watch the video. In fact, I was trying some stuff shown in it.

Thanks James!


Each time you Save Settings, the texture processing begins from scratch. So it can take some time to see what works. As I write this, the error has reappeared.

I suspect it's the normal map slot causing the issue, but I could be wrong. Again, @stephomi would know better.

(Stephomi) #5

Indeed, it's the normal slot.
When you put a texture in the normal slot, we will "normalize" the texture, since each pixel should represent a direction.
Since we don't want to duplicate textures all, the slots that are using this textures will be updated too.

In your case (PBR workflow and only one color texture), I suggest :
- You use "Metalness" workflow
- Put your texture in the BaseColor channel
- If the material is metalllic set metal to 100, otherwise set it to 0 (no texture)
- You can play with the roughness slider (no texture)
- you can play a bit with specular F0 if your object is not metallic but the changes are subtle (no texture)
- You can add your texture in the BumpMap channel (as you did with the torso !)

(Nestor F. Marques) #6

I did as you said and it worked.

Thanks a lot! marble is marble again! smiley