Desktop VR - Models 'wobble' while viewing

Really nice to see more VR support in Sketchfab! Appreciate it SF Team :slight_smile:

The issue I’m having is a strange one. Every model I load ‘wobbles’ slightly, side to side. It’s not the VR environment, the floor grid is perfectly stable as expected, just the model itself shifts about in space several times per second. It doesn’t move far, just a few units I guess and always within range of its origin. It doesn’t seem to matter if it’s a complex or simple model, they all do the same little shimmy. The effect is extremely hard on the eyes. Effect happens with and without the controllers connected, so they’re probably not to blame.

I’m using:
Google Chrome Version 100.0.4896.127 (Official Build) (64-bit)
SteamVR 1.21.12 - Valve Index

Hi,

very indeed strange, seems something went wrong on some pixel jittering
Unfortunately we don’t have any valve index; Could you try an url of r a model with some urloptions ?

  1. `https://sketchfab.com/models/7ddedfb652bd4ea091bc3de27f98fc02/embed?autostart=1&taa=0

  2. https://sketchfab.com/models/7ddedfb652bd4ea091bc3de27f98fc02/embed?autostart=1&taa=1&continuous_render=1

  3. https://sketchfab.com/models/7ddedfb652bd4ea091bc3de27f98fc02/embed?autostart=1&taa=0&drs=0

  4. https://sketchfab.com/models/7ddedfb652bd4ea091bc3de27f98fc02/embed?autostart=1&taa=1&drs=1

And tell us if the wobble is still here in 1/2/3/4 ?

Also just in case, are you using any SteamVR advanced options ? If that’s the case, if you can try with and without it could help pinpoint
( like dynamic resolution, motion smoothing and stuff )

Sorry it took a bit to get back to you on this.

From the tests, it would appear to be the ‘taa’ causing the issue. Both 1 and 3 (taa=0) were normal, 2 and 4 were wobbly. I confirmed it by flipping the ‘taa=1’ to ‘taa=0’ back and forth to check. Is that temporal anti-aliasing?

I tried a variety of VR settings, motion smoothing, dynamic resolution, changing the refresh rate… none of them seemed to make any difference, it was all down to the ‘taa’ setting.

Hope that helps! Going to make a note of that URL query string so I can view some models wobble-free :slight_smile: