Disabling Sound


(JERSIED) #1

This is an odd request coming from a bit of an edge case.

I wear hearing aids, and my iphone streams any sounds to my hearing aids automagically.

Whenever I load my website with my embedded model, the website tries to start to stream audio to my hearing aids, but my 3D scene has no audio associated with it so after three or four seconds it cuts back out and everything returns to normal. (Causes a weird audio channel change effect in my hearing aids and prevents proper hearing amplification).

Is there any way for me to force the audio off? I’ve searched and not found anythign.


(Paul Sketch) #2

what happens if you mute sound ?
(on a model page with sound, click on the “speaker icon”, so it should mute it.)

Not sure it will work, but worth a try,

Problem is from current “chrome sound permission” API, as it just doesn’t exist and only way to check if we have to right is trying to use sound…


#3

Maybe you could add sound_enable: 0 to your model initialization options?


(JERSIED) #4

I’ll try that, thanks!


(JERSIED) #5

Keep in mind it should AUTOMATICALLY be set to 0 if there is no sound assigned to the model. :slight_smile: