Download not working and glTF files aren't rendering properly


(Dulceriver) #1

Download function is not working properly, my glTF download is broken.


#2

I’m sorry you’re having trouble. Which model?


(Dulceriver) #3

Hello James, this is the model I’m having issues with… https://sketchfab.com/models/2f812788888d480eb1a5c6b0371fbb21#

I’m also having issues texturing the models, and optimizing the glTF for optimal view in a-frame-ar.js

Can you please assist me with some tips and suggestions? I can share with you the project I’m working on so you can see the issues I’m having.

Thanks
Dulce B.


#4

I was able to download the glTF file for that model.

Maybe @waleguene can help, he’s been working a lot on our glTF features.


(Dulceriver) #5

The glTF model downloads now but the quality of the output is off. I’m going to try loading a new one now.


(Waleguene) #6

Hi @dulceriver,

We are currently reprocessing all our glTF since we updated our export code. The model was probably not accessible due to this operation, but the asset is now available again.

I took a look at the model you pasted, tried to load it on https://gltf-viewer.donmccurdy.com/ (which is one of our reference viewer) and a few things poped up.
The main issue is that faces are actually inverted for most (and maybe all) the meshes. You can see it when switching from “Double sided” to “Single sided” for each materials in the editor (also note that the doubleSided flag is correctly set in the glTF file, so maybe the renderer is not taking it into account).
When looking at the scene graph, it seems that a few nodes have negative scales (like [-1, -1, -1]), which is probably the cause of these inverted faces. This can be fixed by “applying transforms” or such operators.

Another point to note is that the model has Specular PBR materials, which are still an extension in the glTF format, and not supported by all engines.
Could you check if this extension is supported by the renderer you’re using ? If it’s not the case, it can explain that textures are not applied to the model.

If it’s not one of the mentionned issues, could you give us more details so that we can investigate with you ?

Thanks,


(Dulceriver) #7

I’m rendering these glTF models through webGL in Safari. If you would like to see what I’m working on please download the attached trigger and go to this url… https://www.stealthsavestheday.com

… Please choose the “Protect The Office” experience. Also please makes sure you are standing a bit away from the trigger with a model device… Safari, Firefox or Chrome should work.

I will try your suggestions and reload the models to see if that helps. Thank you.